Bug 984156 - Please re-enable joystick support (joydev module)
Please re-enable joystick support (joydev module)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 01:41 EDT by Alex G.
Modified: 2013-09-16 14:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 09:15:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex G. 2013-07-13 01:41:17 EDT
Description of problem:
Joysticks do not work out of the box on F19, although they worked very well in the past.

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
0. Plug in a USB joystick
1. Fresh F19 install
2. Plug in joystick
3. In KDE, go to System Settings -> Input devices -> Joystick

Actual results:
"No Joystick detected"

Expected results:
Joystick is detected and works.

Additional info:
I had to install kernel-modules-extra then "# modprobe joydev" to get the joystick running. This is too much for an average Joe wanting to play FlightGear. Joysticks are still available on store shelves, so requiring special steps to use such a simple device is very difficult for non-technical users. Please re-include joystick support in the kernel, not an extra package.
Comment 1 Alex G. 2013-09-16 09:17:45 EDT
I apologize for my lack of mind-reading ability, but we "WONTFIX" a bug without even a brief explanation?
Comment 2 Josh Boyer 2013-09-16 14:32:01 EDT
You're the first person to ask about joydev modules since we created the kernel-modules-extra package.  Either people have figured it out since then, or their usage isn't as common as some my perceive.

Note You need to log in before you can comment on or make changes to this bug.