Bug 984190 - USB HDD: Device not responding to set address after resuming from suspend
USB HDD: Device not responding to set address after resuming from suspend
Status: CLOSED DUPLICATE of bug 984189
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 08:37 EDT by Philipp Dreimann
Modified: 2013-07-15 16:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 16:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philipp Dreimann 2013-07-13 08:37:14 EDT
Description of problem:
My usb3 hard drive is not working after a suspend/resume cycle if it is connected to an usb3 port of my docking station. I could, so far, not reproduce it with usb2. I guess it is a timing problem because it seems to depend on the duration the system (or rather the hard drive) is suspended. I attached a filtered dmesg output of a slow and fast suspend/resume cycle. A lsusb output is attached.


Version-Release number of selected component (if applicable):
Kernel 3.9.9-301.fc19.x86_64. I tried 3.10 too, but it did not make any difference.

How reproducible:
Always.

Steps to Reproduce:
1. Attach a external harddrive
2. Suspend to ram
3. Wait a few minutes (important)
4. Resume


Actual results:

<Attaching the device>
usb 4-2: new SuperSpeed USB device number 8 using xhci_hcd
usb 4-2: Parent hub missing LPM exit latency info.  Power management will be impacted.
usb 4-2: New USB device found, idVendor=054c, idProduct=c005
usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 4-2: Product: USB 3.0 SATA Bridge           
usb 4-2: Manufacturer: VIA Technologies Inc.         
usb 4-2: SerialNumber: lþmµóA¹ñô\xffffffc2\xffffff80ô¥7õ\d
scsi10 : usb-storage 4-2:1.0
scsi 10:0:0:0: Direct-Access     Hitachi  HDS5C3030BLE     MZ6O PQ: 0 ANSI: 6
sd 10:0:0:0: Attached scsi generic sg1 type 0
sd 10:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 10:0:0:0: [sdb] Write Protect is off
sd 10:0:0:0: [sdb] Mode Sense: 2f 00 00 00
sd 10:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sd 10:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
 sdb: sdb2 sdb3
sd 10:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 10:0:0:0: [sdb] Attached SCSI disk
EXT4-fs (sdb2): recovery complete
EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
SELinux: initialized (dev sdb2, type ext4), uses xattr
bio: create slab <bio-1> at 1
bio: create slab <bio-1> at 1
EXT4-fs (dm-0): recovery complete
EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
SELinux: initialized (dev dm-0, type ext4), uses xattr

<Suspend/Resume Start>
PM: Syncing filesystems ... done.
PM: Preparing system for mem sleep
Freezing user space processes ... (elapsed 0.01 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
sd 0:0:0:0: [sda] Synchronizing SCSI cache
sd 0:0:0:0: [sda] Stopping disk
mei 0000:00:16.0: suspend
PM: suspend of devices complete after 758.059 msecs
PM: late suspend of devices complete after 0.170 msecs
pcieport 0000:00:1c.6: System wakeup enabled by ACPI
ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
ehci-pci 0000:00:1d.0: power state changed by ACPI to D3hot
ehci-pci 0000:00:1a.0: System wakeup enabled by ACPI
ehci-pci 0000:00:1a.0: power state changed by ACPI to D3hot
PM: noirq suspend of devices complete after 65.733 msecs
ACPI: Preparing to enter system sleep state S3
PM: Saving platform NVS memory
Disabling non-boot CPUs ...
Broke affinity for irq 48
smpboot: CPU 1 is now offline
smpboot: CPU 2 is now offline
Broke affinity for irq 16
Broke affinity for irq 23
Broke affinity for irq 40
Broke affinity for irq 41
smpboot: CPU 3 is now offline
ACPI: Low-level resume complete
PM: Restoring platform NVS memory
Enabling non-boot CPUs ...
smpboot: Booting Node 0 Processor 1 APIC 0x1
Disabled fast string operations
Intel pstate controlling: cpu 1
CPU1 is up
smpboot: Booting Node 0 Processor 2 APIC 0x2
Disabled fast string operations
Intel pstate controlling: cpu 2
CPU2 is up
smpboot: Booting Node 0 Processor 3 APIC 0x3
Disabled fast string operations
Intel pstate controlling: cpu 3
CPU3 is up
ACPI: Waking up from system sleep state S3
ehci-pci 0000:00:1a.0: power state changed by ACPI to D0
ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
ehci-pci 0000:00:1d.0: power state changed by ACPI to D0
ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
sdhci-pci 0000:0d:00.0: MMC controller base frequency changed to 50Mhz.
pcieport 0000:00:1c.6: System wakeup disabled by ACPI
PM: noirq resume of devices complete after 122.192 msecs
PM: early resume of devices complete after 0.123 msecs
ehci-pci 0000:00:1a.0: setting latency timer to 64
usb usb3: root hub lost power or was reset
usb usb4: root hub lost power or was reset
ehci-pci 0000:00:1d.0: setting latency timer to 64
xhci_hcd 0000:0e:00.0: irq 41 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 42 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 43 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 44 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 45 for MSI/MSI-X
usb 1-1.6: reset high-speed USB device number 4 using ehci-pci
ata5: SATA link down (SStatus 0 SControl 300)
ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
ata1.00: configured for UDMA/133
sd 0:0:0:0: [sda] Starting disk
usb 3-2: reset high-speed USB device number 7 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880107b73180
usb 3-2.2: reset high-speed USB device number 8 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880107af7000
usb 3-2.2.2: reset low-speed USB device number 10 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801058ef040
usb 3-2.2.2: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
usb 3-2.2.4: reset low-speed USB device number 11 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801686f30c0
usb 3-2.2.4: ep 0x81 - rounding interval to 128 microframes, ep desc says 192 microframes
PM: resume of devices complete after 1467.194 msecs
PM: Finishing wakeup.
usb 4-2: USB disconnect, device number 8
Restarting tasks ... done.
video LNXVIDEO:00: Restoring backlight state
xHCI xhci_drop_endpoint called with udev and virt_dev does not match
xHCI xhci_drop_endpoint called with udev and virt_dev does not match
xHCI xhci_check_bandwidth called with udev and virt_dev does not match
xHCI xhci_free_dev called with udev and virt_dev does not match
hub 3-2:1.0: unable to enumerate USB device on port 5
Buffer I/O error on device dm-0, logical block 180912128
lost page write due to I/O error on dm-0
JBD2: Error -5 detected when updating journal superblock for dm-0-8.
Buffer I/O error on device dm-0, logical block 180912128
lost page write due to I/O error on dm-0
JBD2: Error -5 detected when updating journal superblock for dm-0-8.
Buffer I/O error on device dm-0, logical block 180912128
lost page write due to I/O error on dm-0
JBD2: Error -5 detected when updating journal superblock for dm-0-8.
Buffer I/O error on device dm-0, logical block 0
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 362738928
Buffer I/O error on device dm-0, logical block 362738928
Buffer I/O error on device dm-0, logical block 362738942
Buffer I/O error on device dm-0, logical block 362738942
Buffer I/O error on device dm-0, logical block 0
Buffer I/O error on device dm-0, logical block 0
usb 4-2: Device not responding to set address.
iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
iwlwifi 0000:03:00.0: Radio type=0x1-0x2-0x0
usb 4-2: Device not responding to set address.
usb 4-2: device not accepting address 9, error -71
hub 4-0:1.0: unable to enumerate USB device on port 2
<The device is not usable>

<Removing and attaching of the device>
usb 4-2: new SuperSpeed USB device number 11 using xhci_hcd
usb 4-2: Parent hub missing LPM exit latency info.  Power management will be impacted.
usb 4-2: New USB device found, idVendor=054c, idProduct=c005
usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 4-2: Product: USB 3.0 SATA Bridge           
usb 4-2: Manufacturer: VIA Technologies Inc.         
usb 4-2: SerialNumber: lþmµóA¹ñô\xffffffc2\xffffff80ô¥7õ\d
scsi11 : usb-storage 4-2:1.0
scsi 11:0:0:0: Direct-Access     Hitachi  HDS5C3030BLE     MZ6O PQ: 0 ANSI: 6
sd 11:0:0:0: Attached scsi generic sg1 type 0
sd 11:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 11:0:0:0: [sdb] Write Protect is off
sd 11:0:0:0: [sdb] Mode Sense: 2f 00 00 00
sd 11:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sd 11:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
 sdb: sdb2 sdb3
sd 11:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 11:0:0:0: [sdb] Attached SCSI disk
EXT4-fs (sdb2): recovery complete
EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
SELinux: initialized (dev sdb2, type ext4), uses xattr
bio: create slab <bio-1> at 1
bio: create slab <bio-1> at 1
EXT4-fs (dm-0): recovery complete
EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)

<Fast Suspend/Resume>
PM: Syncing filesystems ... done.
PM: Preparing system for mem sleep
Freezing user space processes ... (elapsed 0.01 seconds) done.
Freezing remaining freezable tasks ... (elapsed 0.01 seconds) done.
PM: Entering mem sleep
Suspending console(s) (use no_console_suspend to debug)
sd 0:0:0:0: [sda] Synchronizing SCSI cache
sd 0:0:0:0: [sda] Stopping disk
mei 0000:00:16.0: suspend
i915 0000:00:02.0: power state changed by ACPI to D3hot
PM: suspend of devices complete after 756.321 msecs
PM: late suspend of devices complete after 0.184 msecs
pcieport 0000:00:1c.6: System wakeup enabled by ACPI
ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
ehci-pci 0000:00:1d.0: power state changed by ACPI to D3hot
ehci-pci 0000:00:1a.0: System wakeup enabled by ACPI
ehci-pci 0000:00:1a.0: power state changed by ACPI to D3hot
e1000e 0000:00:19.0: System wakeup enabled by ACPI
PM: noirq suspend of devices complete after 65.733 msecs
ACPI: Preparing to enter system sleep state S3
PM: Saving platform NVS memory
Disabling non-boot CPUs ...
Broke affinity for irq 48
smpboot: CPU 1 is now offline
smpboot: CPU 2 is now offline
Broke affinity for irq 16
Broke affinity for irq 23
Broke affinity for irq 40
Broke affinity for irq 41
smpboot: CPU 3 is now offline
ACPI: Low-level resume complete
PM: Restoring platform NVS memory
Enabling non-boot CPUs ...
smpboot: Booting Node 0 Processor 1 APIC 0x1
Disabled fast string operations
Intel pstate controlling: cpu 1
CPU1 is up
smpboot: Booting Node 0 Processor 2 APIC 0x2
Disabled fast string operations
Intel pstate controlling: cpu 2
CPU2 is up
smpboot: Booting Node 0 Processor 3 APIC 0x3
Disabled fast string operations
Intel pstate controlling: cpu 3
CPU3 is up
ACPI: Waking up from system sleep state S3
ehci-pci 0000:00:1a.0: power state changed by ACPI to D0
ehci-pci 0000:00:1a.0: System wakeup disabled by ACPI
ehci-pci 0000:00:1d.0: power state changed by ACPI to D0
ehci-pci 0000:00:1d.0: System wakeup disabled by ACPI
pcieport 0000:00:1c.6: System wakeup disabled by ACPI
PM: noirq resume of devices complete after 121.147 msecs
PM: early resume of devices complete after 0.124 msecs
ehci-pci 0000:00:1a.0: setting latency timer to 64
ehci-pci 0000:00:1d.0: setting latency timer to 64
ahci 0000:00:1f.2: setting latency timer to 64
usb usb3: root hub lost power or was reset
usb usb4: root hub lost power or was reset
xhci_hcd 0000:0e:00.0: irq 41 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 42 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 43 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 44 for MSI/MSI-X
xhci_hcd 0000:0e:00.0: irq 45 for MSI/MSI-X
usb 1-1.6: reset high-speed USB device number 4 using ehci-pci
ata5: SATA link down (SStatus 0 SControl 300)
ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
ata1.00: ACPI cmd ef/02:00:00:00:00:a0 (SET FEATURES) succeeded
ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
ata1.00: configured for UDMA/133
sd 0:0:0:0: [sda] Starting disk
usb 4-2: reset SuperSpeed USB device number 11 using xhci_hcd
usb 4-2: Parent hub missing LPM exit latency info.  Power management will be impacted.
usb 4-2: device firmware changed
usb 3-2: reset high-speed USB device number 7 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880107b73180
usb 3-2.2: reset high-speed USB device number 8 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff880107af7000
usb 3-2.2.4: reset low-speed USB device number 11 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801686f30c0
usb 3-2.2.4: ep 0x81 - rounding interval to 128 microframes, ep desc says 192 microframes
usb 3-2.2.2: reset low-speed USB device number 10 using xhci_hcd
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff8801058ef040
usb 3-2.2.2: ep 0x81 - rounding interval to 64 microframes, ep desc says 80 microframes
PM: resume of devices complete after 1599.202 msecs
PM: Finishing wakeup.
usb 4-2: USB disconnect, device number 11
Restarting tasks ... done.
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88016fe7d200
xhci_hcd 0000:0e:00.0: xHCI xhci_drop_endpoint called with disabled ep ffff88016fe7d240
video LNXVIDEO:00: Restoring backlight state
quiet_error: 151 callbacks suppressed
Buffer I/O error on device dm-0, logical block 180912128
lost page write due to I/O error on dm-0
JBD2: Error -5 detected when updating journal superblock for dm-0-8.
Buffer I/O error on device dm-0, logical block 180912128
lost page write due to I/O error on dm-0
JBD2: Error -5 detected when updating journal superblock for dm-0-8.
Buffer I/O error on device dm-0, logical block 0
lost page write due to I/O error on dm-0
Buffer I/O error on device dm-0, logical block 362738928
Buffer I/O error on device dm-0, logical block 362738928
Buffer I/O error on device dm-0, logical block 362738942
Buffer I/O error on device dm-0, logical block 362738942
Buffer I/O error on device dm-0, logical block 0
Buffer I/O error on device dm-0, logical block 0
Buffer I/O error on device dm-0, logical block 1
usb 4-2: new SuperSpeed USB device number 12 using xhci_hcd
usb 4-2: Parent hub missing LPM exit latency info.  Power management will be impacted.
usb 4-2: New USB device found, idVendor=054c, idProduct=c005
usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 4-2: Product: USB 3.0 SATA Bridge           
usb 4-2: Manufacturer: VIA Technologies Inc.         
usb 4-2: SerialNumber: 66260365A454MZ6O
scsi12 : usb-storage 4-2:1.0
scsi 12:0:0:0: Direct-Access     Hitachi  HDS5C3030BLE     MZ6O PQ: 0 ANSI: 6
sd 12:0:0:0: Attached scsi generic sg1 type 0
sd 12:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 12:0:0:0: [sdb] Write Protect is off
sd 12:0:0:0: [sdb] Mode Sense: 2f 00 00 00
sd 12:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
sd 12:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
 sdb: sdb2 sdb3
sd 12:0:0:0: [sdb] 732566646 4096-byte logical blocks: (3.00 TB/2.72 TiB)
sd 12:0:0:0: [sdb] Attached SCSI disk
EXT4-fs (sdb2): recovery complete
EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
SELinux: initialized (dev sdb2, type ext4), uses xattr
bio: create slab <bio-1> at 1
bio: create slab <bio-1> at 1
EXT4-fs (dm-0): recovery complete
EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
SELinux: initialized (dev dm-0, type ext4), uses xattr


Expected results:
The hard disk should be accessible.
Comment 1 Philipp Dreimann 2013-07-15 16:12:13 EDT

*** This bug has been marked as a duplicate of bug 984189 ***

Note You need to log in before you can comment on or make changes to this bug.