Bug 984210 - Missing dependency 'python-setuptools' for PyMunin
Missing dependency 'python-setuptools' for PyMunin
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: PyMunin (Show other bugs)
el6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 12:47 EDT by Malte Kraus
Modified: 2014-09-17 09:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: PyMunin-0.9.19-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-10 00:00:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Malte Kraus 2013-07-13 12:47:57 EDT
At least the phpfpmstats munin plugin from the PyMunin package requires the 'pkg_resources' module from python-setuptools.

Version-Release number: 0.9.19-1.el6

Steps to Reproduce:
1. Install PyMunin
2. Enable the phpfpmstats plugin (ln -s /usr/share/munin/plugins/phpfpmstats /etc/munin/plugins/)
3. Run the plugin (munin-run phpfpmstats)

Actual results:
Traceback (most recent call last):
  File "/etc/munin/plugins/phpfpmstats", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
Comment 1 Fedora Update System 2013-07-30 01:47:53 EDT
PyMunin-0.9.27-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/PyMunin-0.9.27-2.fc19
Comment 2 Fedora Update System 2013-07-30 01:48:55 EDT
PyMunin-0.9.19-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/PyMunin-0.9.19-2.el6
Comment 3 Fedora Update System 2013-08-01 16:43:42 EDT
Package PyMunin-0.9.19-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing PyMunin-0.9.19-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11089/PyMunin-0.9.19-2.el6
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-10 00:00:22 EDT
PyMunin-0.9.27-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-08-10 08:35:33 EDT
PyMunin-0.9.27-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-08-16 15:54:29 EDT
PyMunin-0.9.19-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Chris Butler 2014-09-17 09:49:49 EDT
I just installed PyMunin 0.9.19-2.el6 on my CentOS 6 system, and the python-setuptools package was not installed. It looks like this bug has not been fixed:

[chrisb@db1 plugins]$ rpm -q PyMunin
PyMunin-0.9.19-2.el6.noarch
[chrisb@db1 plugins]$ rpm -qR PyMunin
/usr/bin/python  
munin-node  
python(abi) = 2.6
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

Note You need to log in before you can comment on or make changes to this bug.