Bug 984220 - transmission daemon built without systemd-support, won't start
transmission daemon built without systemd-support, won't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 13:33 EDT by Tomasz Torcz
Modified: 2013-07-18 01:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: transmission-2.80-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 01:52:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add systemd-devel BR fo daemon (985 bytes, patch)
2013-07-13 13:33 EDT, Tomasz Torcz
no flags Details | Diff

  None (edit)
Description Tomasz Torcz 2013-07-13 13:33:42 EDT
Created attachment 773120 [details]
add systemd-devel BR fo daemon

Description of problem:
2.80-1.fc19 is built without systemd support.  You can check it in build.log:

checking for SYSTEMD_DAEMON... no

This happens because configure script calls pkg-config to find libsystemd-daemon. And it only works if systemd-devel is installed:

% rpm -qf /usr/lib64/pkgconfig/libsystemd-daemon.pc
systemd-devel-204-9.fc19.x86_64

  Without systemd support, transmission-daemon won't send proper notifies and will not start - systemd will hit a timeout waiting for notify and will kill the daemon.
  The fix is to add systemd-devel to buildrequires.
Comment 1 Igor Gnatenko 2013-07-13 14:01:46 EDT
Yes. Confirm.
Comment 2 Ankur Sinha (FranciscoD) 2013-07-13 23:02:34 EDT
Hi,


Thank you for your bug report. I'll push a fix first thing tomorrow morning. I haven't access to my laptop today.

Thanks,
Warm regards, 
Ankur.
Comment 3 Fedora Update System 2013-07-14 19:27:36 EDT
transmission-2.80-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/transmission-2.80-2.fc19
Comment 4 Phil Anderson 2013-07-15 08:25:29 EDT
It is worth noting that this update also changes the location of the config file from:
/var/lib/transmission/.config/transmission
to:
/var/lib/transmission/.config/transmission-daemon

So, after upgrading, all torrents, settings, etc will be lost.  Is this intentional, or is this a bug?
Comment 5 Rahul Sundaram 2013-07-15 13:48:49 EDT
It is a intentional change. We used to include a custom systemd service file that handled this in previous versions and since upstream 2.80 release now includes a systemd service file, we have dropped our Fedora specific one.  So you will have to move your configuration file to this new location.  Sorry about the hassle but it will be a one time change.  The idea behind systemd is to unify these type of configuration changes across distributions and Fedora tends to stay as close to upstream software as feasible generally.  

@Ankur, please note this change in the bodhi update.
Comment 6 Fedora Update System 2013-07-15 21:49:09 EDT
Package transmission-2.80-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing transmission-2.80-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13033/transmission-2.80-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-18 01:52:52 EDT
transmission-2.80-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.