Bug 984244 - dhcpd must not claim to listen on ipv6 on ipv4-machines
dhcpd must not claim to listen on ipv6 on ipv4-machines
Status: CLOSED DUPLICATE of bug 962950
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 19:33 EDT by Harald Reindl
Modified: 2013-07-15 09:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 09:43:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-07-13 19:33:14 EDT
why does dhcpd/ntpd and samba claim to be different as any other network services? there is no interfcace with a ipv6-address, dhcpd is even started with "-4" and netstat says it claims a udp6 high port nobody knows for what

[root@srv-rhsoft:~]$ ps aux | grep 18637
dhcpd    18637  0.0  0.1 109516 18508 ?        Ss   01:15   0:00 /usr/sbin/dhcpd -4 -f -cf /etc/dhcp/dhcpd-guest.conf -lf /var/lib/dhcpd/dhcpd-guest.leases -user dhcpd -group dhcpd --no-pid br1

[root@srv-rhsoft:~]$ netstat -l | grep 18637
udp        0      0 0.0.0.0:67              0.0.0.0:*                           18637/dhcpd
udp        0      0 0.0.0.0:44827           0.0.0.0:*                           18637/dhcpd
udp6       0      0 :::57860                :::*                                18637/dhcpd

[root@srv-rhsoft:~]$ cat /etc/sysctl.conf | grep ipv6
net.ipv6.conf.all.disable_ipv6=1
net.ipv6.conf.all.accept_redirects=0
net.ipv6.conf.all.accept_source_route=0
net.ipv6.conf.default.disable_ipv6=1
net.ipv6.conf.default.accept_redirects=0
net.ipv6.conf.default.accept_source_route=0
Comment 1 Jiri Popelka 2013-07-15 09:43:37 EDT

*** This bug has been marked as a duplicate of bug 962950 ***
Comment 2 Harald Reindl 2013-07-15 09:48:27 EDT
this is hardly a duplicate because 962950 talks about dhclient
while these is about dhcpd

Note You need to log in before you can comment on or make changes to this bug.