Bug 984247 - Version 1.3.0 final
Version 1.3.0 final
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shapelib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 20:11 EDT by Sandro Mani
Modified: 2013-08-17 20:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: shapelib-1.3.0f-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 20:31:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2013-07-13 20:11:03 EDT
Needing shapelib for a project of mine, I've worked to update it to the latest 1.3.0 release. The SPEC and SRPM are here:
SPEC: http://smani.fedorapeople.org/shapelib.spec
SRPM: http://smani.fedorapeople.org/shapelib-1.3.0f-1.fc20.src.rpm

Two notes:
- Since I also need a mingw variant and got tired of hacking the handwritten makefiles, I wrote autotools build scripts instead (see https://github.com/manisandro/shapelib/tree/autotools). I've then created a patch against the upstream 1.3.0 version, which is used in the package. The steps for generating the patch are outlined in the spec file.
- Since the previous NVR was 1.3.0b2-x instead of 1.3.0-0.x.b2, to make 1.3.0 > 1.3.0b2, I've added an f at the end of the version (i.e. 1.3.0f). The alternative would be to bump the epoch, which however should be avoided since, once bumped, it'll stay forever.

By the way, I'm happy to comaintain the package if desired.
Comment 1 Sandro Mani 2013-07-20 06:11:08 EDT
Ping?
Comment 2 Fedora Admin XMLRPC Client 2013-08-05 13:22:27 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Update System 2013-08-05 13:37:36 EDT
shapelib-1.3.0f-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/shapelib-1.3.0f-1.fc19
Comment 4 Fedora Update System 2013-08-06 19:34:45 EDT
Package shapelib-1.3.0f-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shapelib-1.3.0f-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14334/shapelib-1.3.0f-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-08 15:39:39 EDT
shapelib-1.3.0f-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/shapelib-1.3.0f-2.fc19
Comment 6 Fedora Update System 2013-08-17 20:31:35 EDT
shapelib-1.3.0f-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.