Bug 984250 - ksh leaks memory when nested `` is used.
ksh leaks memory when nested `` is used.
Status: CLOSED DUPLICATE of bug 921455
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-13 20:31 EDT by Tetsuo Handa
Modified: 2013-07-23 03:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 09:46:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tetsuo Handa 2013-07-13 20:31:04 EDT
Description of problem:

Running below command continues eating memory.

$ ksh -c 'while :; do echo -n `true \`true\``; done'

Version-Release number of selected component (if applicable):
ksh-20100621-19.el6_4.4

How reproducible:
Always.

Steps to Reproduce:
1. Install ksh and run commands with nested ``. 

  $ ksh -c 'while :; do echo -n `true \`true\``; done'

Actual results:
top command reports that ksh continues eating memory.

Expected results:
top command reports that ksh does not continue eating memory.

Additional info:
RHEL 6.4's ksh-20100621-19.el6_4.4 has this bug.
Fedora 19's ksh-20120801-8.fc19 does not have this bug.
Comment 2 Michal Hlavinka 2013-07-22 09:46:42 EDT
covered by fix for reproducer at bug #921455 comment #5

*** This bug has been marked as a duplicate of bug 921455 ***
Comment 3 Tetsuo Handa 2013-07-22 18:57:27 EDT
Bug 921455 is not visible. Can I expect that this bug will be fixed in RHEL6?
Comment 4 Michal Hlavinka 2013-07-23 03:24:14 EDT
(In reply to Tetsuo Handa from comment #3)
> Bug 921455 is not visible. Can I expect that this bug will be fixed in RHEL6?

99% yes

Note You need to log in before you can comment on or make changes to this bug.