Bug 984270 - Allow volume type to be changed for an existing volume (volume retype)
Allow volume type to be changed for an existing volume (volume retype)
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: Upstream M2
: 5.0 (RHEL 7)
Assigned To: Eric Harney
Yogev Rabl
https://blueprints.launchpad.net/cind...
storage upstream_milestone_icehouse-2...
: Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 06:55 EDT by Dafna Ron
Modified: 2016-04-26 14:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
With this release, you can now modify a given volume's type. When modifying a volume's type, the Block Storage scheduler checks if the volume's current host can accept the new type: as in, the scheduler checks if the host passes the filters when using the specified type. If the current host is suitable, the volume's corresponding manager then calls the right driver to change the volume's type accordingly. If the current host cannot accept the new type, or if the volume driver is unable to modify the volume's type, then you will need to migrate the volume in order to change the volume type. Specifically, you will need to create a new volume of the type you want, and then migrate the contents of original volume to this one.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:29:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (4.96 KB, application/x-gzip)
2013-07-14 06:55 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 44881 None None None Never
OpenStack gerrit 47124 None None None Never

  None (edit)
Description Dafna Ron 2013-07-14 06:55:45 EDT
Created attachment 773272 [details]
logs

Description of problem:

we can add a volume with --volume-type but if we delete the type and its removed from the volume we have no way of attaching a new type. 

Version-Release number of selected component (if applicable):

openstack-cinder-2013.1.2-3.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a volume type 
2. create a new volume and add --volume-type with the type you created 
3. delete the type 
4. create a new type

Actual results:

we cannot add a new type to a new volume but we cannot add a type to an existing volume 

Expected results:

we should be able to add a type to a new volume.
there are other params that we should allow to be used (lvextend and other params that should be added to an edit command) 

Additional info:
Comment 1 Eric Harney 2013-09-09 11:57:59 EDT
https://review.openstack.org/#/c/44258/ changes the assumptions here a bit.  It will no longer be possible to delete a volume type when volumes of that type still exist.
Comment 2 Stephen Gordon 2014-01-23 15:50:59 EST
Moving to POST based on upstream status (Implemented).
Comment 4 Yogev Rabl 2014-06-03 04:08:05 EDT
verified on:
openstack-cinder-2014.1-3.1.el7ost.noarch
python-cinder-2014.1-3.1.el7ost.noarch
python-cinderclient-1.0.8-1.el7ost.noarch

with the bugs: 
Bug 1104052
Bug 1103503
Bug 1103500
Comment 7 errata-xmlrpc 2014-07-08 11:29:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0852.html

Note You need to log in before you can comment on or make changes to this bug.