Bug 984289 - virsh is unusable from ssh or non-graphical environment under default polkit setup
virsh is unusable from ssh or non-graphical environment under default polkit ...
Status: CLOSED DUPLICATE of bug 872166
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
19
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 09:58 EDT by David Gibson
Modified: 2013-07-15 16:03 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 16:03:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gibson 2013-07-14 09:58:05 EDT
Description of problem:

The default configuration of authentication between polkit and libvirt makes virsh unusable from an ssh session or text console where it does not have access to a desktop environment's polkit agent.

Version-Release number of selected component (if applicable):

libvirt-client-1.0.5.2-1.fc19.x86_64


How reproducible:


Steps to Reproduce:
1. Log in on a text console, or ssh to localhost
2. virsh -c qemu:///system list

Actual results:

$ virsh -c qemu:///system list
error: failed to connect to the hypervisor
error: no valid connection
error: authentication failed: polkit: polkit\56retains_authorization_after_challenge=1
Authorization requires authentication but no agent is available.

Expected results:

Some means of authenticating to allow virsh to continue.
Comment 1 Cole Robinson 2013-07-15 16:03:58 EDT

*** This bug has been marked as a duplicate of bug 872166 ***

Note You need to log in before you can comment on or make changes to this bug.