This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984305 - fedup doesn't remove obsoleted packages
fedup doesn't remove obsoleted packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 12:55 EDT by Martin B.
Modified: 2013-12-06 16:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 16:02:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedup logs (322.18 KB, application/gzip)
2013-08-05 17:36 EDT, Martin B.
no flags Details

  None (edit)
Description Martin B. 2013-07-14 12:55:32 EDT
Description of problem
======================

Fedup doesn't remove packages which were declared as obsolete (and so are not   
included in the new fedora release). This leads to dependency conflicts in rpm  
database.

Version-Release number of selected component (if applicable)
============================================================

fedup-0.7.3-4.fc18.noarch

How reproducible
================

Tried once, given the nature of the issue guessing "always".

Steps to Reproduce
==================

1. on Fedora 18, install glusterfs-swift
2. update to Fedora 19 via fedup
3. run 'yum check'

Actual results
==============

yum check (which is btw run in every yum update) fails:

~~~
# yum check                                                                     
Loaded plugins: etckeeper, langpacks, ps, refresh-packagekit, verify, versionlock
glusterfs-swift-3.3.1-15.fc18.noarch has installed conflicts openstack-swift: openstack-swift-1.8.0-2.fc19.noarch
glusterfs-swift-3.3.1-15.fc18.noarch has missing requires of glusterfs = ('0', '3.3.1', '15.fc18')
Error: check all 
~~~

Expected results
================

Package glusterfs-swift is not installed. Since it was removed in fedora 19[1], 
fedup make sure this package is removed.

Additional info
===============

[1] from glusterfs changelog:                                                   
                                                                                
> * Mon Jul 8 2013 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 3.4.0-0.9.beta4   
> - add Obsolete: glusterfs-swift where we use openstack-swift                    
> - prerelease 3.4.0beta4 for oVirt/vdsm dependencies in Fedora19                 

For the fedup upgrade, I used fedup from fedora 18 but I filled this BZ for f19
to last longer since both fedora versions should contain the same fedup version
(checked via fedpkg).

~~~
# grep fedup yum.log
Feb 17 03:16:23 Installed: fedup-0.7.3-0.git20130128.fc17.noarch
May 15 23:58:19 Updated: fedup-0.7.3-4.fc18.noarch
# rpm -q fedup
fedup-0.7.3-4.fc19.noarch
~~~
Comment 1 Will Woods 2013-08-05 11:14:19 EDT
Could you attach your fedup.log and upgrade.log?
Comment 2 Martin B. 2013-08-05 17:36:17 EDT
Created attachment 783036 [details]
fedup logs

(In reply to Will Woods from comment #1)
> Could you attach your fedup.log and upgrade.log?

both files attached

note that fedup.log also contains entries from previous upgrade, I didn't edit it in any way
Comment 3 Will Woods 2013-12-06 16:02:11 EST
In my testing, fedup definitely removes obsoleted packages when the Obsoletes: entries are correct. 

The problem was that your upgrade was installing glusterfs-3.4.0-0.8.beta4.fc19, which didn't have "Obsoletes: glusterfs-swift". So this was a packaging problem with glusterfs, not a fedup bug.

glusterfs has already fixed the packaging problem, so there's nothing else to do there.
Comment 4 Will Woods 2013-12-06 16:02:58 EST
(whoops, wrong resolution - sorry about that)

Note You need to log in before you can comment on or make changes to this bug.