Bug 984337 - [abrt] firewall-config-0.3.3-2.fc19: firewall-config:1591:onChangeService:AttributeError: 'NoneType' object has no attribute 'getPorts'
[abrt] firewall-config-0.3.3-2.fc19: firewall-config:1591:onChangeService:Att...
Status: CLOSED DUPLICATE of bug 1000054
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:68a6afe596015e236b204388363...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-14 21:10 EDT by Kevin
Modified: 2013-08-22 12:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 12:13:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (723 bytes, text/plain)
2013-07-14 21:10 EDT, Kevin
no flags Details
File: environ (1.33 KB, text/plain)
2013-07-14 21:10 EDT, Kevin
no flags Details

  None (edit)
Description Kevin 2013-07-14 21:10:13 EDT
Description of problem:
GUI firewall-config interface crashed while I was trying to add a new service/port.

Version-Release number of selected component:
firewall-config-0.3.3-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/firewall-config
core_backtrace: 60363ff895931066c15e303f494df3bbb37526fa 0x637 onChangeService /usr/bin/firewall-config -
executable:     /usr/bin/firewall-config
kernel:         3.9.9-301.fc19.x86_64
runlevel:       N 5
uid:            1006

Truncated backtrace:
firewall-config:1591:onChangeService:AttributeError: 'NoneType' object has no attribute 'getPorts'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 1591, in onChangeService
    ports = settings.getPorts()
AttributeError: 'NoneType' object has no attribute 'getPorts'

Local variables in innermost frame:
args: (<TreeSelection object at 0x1c76be0 (GtkTreeSelection at 0x1a05370)>,)
service: <firewall.client.FirewallClientConfigService object at 0x1c80c50>
settings: None
active_service: 'mysql'
self: <__main__.FirewallConfig object at 0x187b350>
destination: {}
modules: []
old_handler: <bound method FirewallConfig._exception_handler of <__main__.FirewallConfig object at 0x187b350>>
ports: []
Comment 1 Kevin 2013-07-14 21:10:23 EDT
Created attachment 773460 [details]
File: backtrace
Comment 2 Kevin 2013-07-14 21:10:26 EDT
Created attachment 773461 [details]
File: environ
Comment 3 Jiri Popelka 2013-07-15 07:10:28 EDT
I can't reproduce this and have no idea how
firewall.client.FirewallClientConfigService.getSettings() could have returned None.

Kevin, are you able to reproduce the crash, or did it happen only once ?
Comment 4 Jiri Popelka 2013-08-22 12:13:58 EDT

*** This bug has been marked as a duplicate of bug 1000054 ***

Note You need to log in before you can comment on or make changes to this bug.