Bug 984382 - [RFE] Provide a separate view for jobs submitted on behalf of the user's groups
[RFE] Provide a separate view for jobs submitted on behalf of the user's groups
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.13
Unspecified Unspecified
urgent Severity unspecified (vote)
: 0.14
: ---
Assigned To: Dan Callaghan
tools-bugs
: FutureFeature, TestCaseApproved, TestCaseProvided
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 02:11 EDT by Nick Coghlan
Modified: 2018-02-05 19:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 23:24:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2013-07-15 02:11:19 EDT
The My Jobs view was updated in 0.13 to show all jobs submitted on behalf of groups of which the user is a member.

This proved to be too noisy in some cases, so the view is being reverted to its previous behaviour in 0.14 (see bug 984374). However, the new view that shows all jobs the user has full access to is also useful and can't easily be constructed as a manual filter, so it should be added as a separate screen in 0.14.

Suggested name for the new screen: "My Group Jobs"

While that name is technically slightly ambiguous (it could be taken mean "jobs I have submitted on behalf of groups" rather than the intended "all jobs submitted on behalf of groups of which I am a member)", the formally correct "My Groups' Jobs" looks strange.
Comment 7 Dan Callaghan 2013-07-22 02:27:44 EDT
Done as part of the patch for bug 984374.
Comment 10 Dan Callaghan 2013-08-08 23:24:07 EDT
Beaker 0.14.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.