Bug 98439 - serial ata causes kernel NULL pointer dereference
serial ata causes kernel NULL pointer dereference
Status: CLOSED NEXTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: 97140
  Show dependency treegraph
 
Reported: 2003-07-02 10:48 EDT by Kaj J. Niemi
Modified: 2013-07-02 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-22 11:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of dmesg from SATA computer (13.19 KB, text/plain)
2003-07-02 10:50 EDT, Kaj J. Niemi
no flags Details
output of lspci -v (2.37 KB, text/plain)
2003-07-02 10:52 EDT, Kaj J. Niemi
no flags Details

  None (edit)
Description Kaj J. Niemi 2003-07-02 10:48:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
Shuttle SB61G2 with Pentium 4 2.4 GHz HT 800 FSB, 1024 MB memory, 1 IDE ATAPI
CD-ROM, 1x Western Digital SATA 36.8 GB hard drive exhibits
"kernel NULL pointer dereference" initializing hard drives at startup.

I tried having the SATA controller in auto, compat, enhanced and SATA only
modes. Auto & compat work, SATA only fails when probing hardware.

Unable to handle kernel NULL pointer dereference at virtual address 00000010
 printing eip:
f89a4296
*pde = 00000000
Oops: 0000
ata_piix libata scsi_mod microcode ohci1394 ieee1394 loop lvm-mod ext3 jbd
CPU:    1
EIP:    0060:[<f89a4296>]    Not tainted
EFLAGS: 00010282
 
EIP is at ata_pci_remove_one_Rsmp_f8bc400c [libata] 0x16 (2.4.20-20.1.2013.nptlsmp)
eax: f89a4280   ebx: 00000000   ecx: f899f14c   edx: f897d3c0
esi: f7cf3000   edi: 00000000   ebp: bff3ac48   esp: f78b9f64
ds: 0068   es: 0068   ss: 0068
Process modprobe (pid: 211, stackpage=f78b9000)
Stack: c034dcf4 00000000 f7cf3000 f89a8c80 c01ddd88 f7cf3000 f89a8000 fffffff0
       f89a8663 f89a8c80 f89a8cc0 c0125672 f89a8000 f89a8000 fffffff0 f7722000
       c01248d7 f89a8000 00000000 00001000 f78b8000 00000000 00000000 c0109daf
Call Trace:   [<f89a8c80>] piix_pci_driver [ata_piix] 0x0 (0xf78b9f70)
[<c01ddd88>] pci_unregister_driver [kernel] 0x58 (0xf78b9f74)
[<f89a8663>] piix_exit [ata_piix] 0x23 (0xf78b9f84)
[<f89a8c80>] piix_pci_driver [ata_piix] 0x0 (0xf78b9f88)
[<f89a8cc0>] piix_sht [ata_piix] 0x0 (0xf78b9f8c)
[<c0125672>] free_module [kernel] 0xd2 (0xf78b9f90)
[<c01248d7>] sys_delete_module [kernel] 0xe7 (0xf78b9fa4)
[<c0109daf>] system_call [kernel] 0x33 (0xf78b9fc0)

Dmesg attached.

Version-Release number of selected component (if applicable):
kernel-smp-2.4.20-20.1.2013.nptl

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to rawhide kernel
2. Reboot
3. Wait for error messages
    

Actual Results:  Fails miserably

Expected Results:  SATA should work 

Additional info:


I'm running latest rawhide on it to get any SATA features at all. Tried RH8/RH9
just for the heck of it but they report unknown controller and performance is
even worse.

% rpm -qa --qf "%-18{name} %-8{version} %-15{release} %{arch}\n" glibc\*
kernel-smp kudzu
glibc-common       2.3.2    57              i386
glibc              2.3.2    57              i686
glibc-devel        2.3.2    57              i386
kudzu              1.1.8    1               i386
kernel-smp         2.4.20   20.1.2013.nptl  i686

Attached is dmesg and lspci
Comment 1 Kaj J. Niemi 2003-07-02 10:50:51 EDT
Created attachment 92718 [details]
Output of dmesg from SATA computer

Output of dmesg
Comment 2 Kaj J. Niemi 2003-07-02 10:52:19 EDT
Created attachment 92719 [details]
output of lspci -v

Output of lspci -v (dunno if it matters)
Comment 4 Kaj J. Niemi 2003-07-22 11:12:08 EDT
Doesn't happen anymore with kernel-smp-2.4.21-20.1.2024.2.1.nptl. Thanks!

Marking NEXTRELEASE since kernel-smp-2.4.21-20.1.2024.2.1.nptl doesn't exist on
rawihde ...
Comment 5 Kaj J. Niemi 2003-09-22 18:48:20 EDT
Yeah, doesn't happen with 2.4.22-* either.

Note You need to log in before you can comment on or make changes to this bug.