Bug 9844 - Dynamic loader dies when loading apache module
Dynamic loader dies when loading apache module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-28 18:59 EST by Chris Seawood
Modified: 2016-11-24 10:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 14:03:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Seawood 2000-02-28 18:59:00 EST
It appears as though the dynamic loader is crashing when I try to load a
custom apache module.  I recompiled apache with debugging on and here's the
trace:

(gdb) r -X
Starting program: /usr/sbin/httpd -X
Cannot access memory at address 0x401e2ab4
(gdb) [Mon Feb 28 15:01:51 2000] [info] v3 server checksum: 10010

bt
#0  0x4000af21 in _dl_debug_state () at dl-debug.c:56
#1  0x4017f9a6 in _dl_close (map=0x80b1010) at dl-close.c:195
#2  0x4009e430 in dlclose_doit (handle=0x80b1010) at dlclose.c:26
#3  0x4000ac3b in _dl_catch_error (errstring=0x400a0080,
    operate=0x4009e418 <dlclose_doit>, args=0x80b1010) at dl-error.c:141
#4  0x4009e8b9 in _dlerror_run (operate=0x4009e418 <dlclose_doit>,
    args=0x80b1010) at dlerror.c:125
#5  0x4009e3fe in dlclose (handle=0x80b1010) at dlclose.c:32
#6  0x8070d36 in ap_os_dso_unload (handle=0x80b1010) at os.c:133
#7  0x804f289 in unload_module (modi=0x80a74bc) at mod_so.c:181
#8  0x8051209 in run_cleanups (c=0x80a83bc) at alloc.c:1706
#9  0x804f8c3 in ap_clear_pool (a=0x80a729c) at alloc.c:531
#10 0x806041c in standalone_main (argc=2, argv=0xbffffb44) at
http_main.c:4614
#11 0x8060d7c in main (argc=2, argv=0xbffffb44) at http_main.c:4981
(gdb) q

The module is also linked staticly against libmysqlclient, and dynamicly
against libpthread, libz & libm.  Unfortunately, the module is proprietary
so I can't really give any more details that this.  The same module worked
fine on RH6.0 using apache 1.3.9 & I just tested that 1.3.11 & 1.3.12 work
under RH6.0 as well.
Comment 1 Cristian Gafton 2000-05-22 10:53:59 EDT
assign to jakub
Comment 2 Stephen John Smoogen 2003-01-24 18:41:38 EST
Is this bug still relevant in Red Hat Linux 7.3 or 8.0? There have been massive
changes in glibc since or the manufacturer of the closed source module might
have seen the light and opensourced it or put in a fix to cover this,.
Comment 3 Jay Turner 2003-04-14 14:03:22 EDT
Closing out due to bit-rot.

Note You need to log in before you can comment on or make changes to this bug.