Bug 984407 - SELinux is preventing /usr/libexec/kde4/lnusertemp from 'create' accesses on the directory .kde.
SELinux is preventing /usr/libexec/kde4/lnusertemp from 'create' accesses on ...
Status: CLOSED DUPLICATE of bug 772325
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:43e36891067671c50a7ae8aaa89...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 03:50 EDT by Vlad
Modified: 2013-07-16 04:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 04:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlad 2013-07-15 03:50:38 EDT
Description of problem:
Не устанавливается драйвер ATI
SELinux is preventing /usr/libexec/kde4/lnusertemp from 'create' accesses on the directory .kde.

*****  Plugin catchall_boolean (89.3 confidence) suggests  *******************

If вы хотите выполнить следующее: allow polyinstantiation to enabled
Then you must tell SELinux about this by enabling the 'polyinstantiation_enabled' boolean.
Дополнительная документация на 'None' ман странице.
Do
setsebool -P polyinstantiation_enabled 1

*****  Plugin catchall (11.6 confidence) suggests  ***************************

If вы считаете, что lnusertemp следует разрешить доступ create к .kde directory по умолчанию.
Then рекомендуется создать отчет об ошибке.
Чтобы разрешить доступ, можно создать локальный модуль политики.
Do
чтобы разрешить доступ, выполните:
# grep lnusertemp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .kde [ dir ]
Source                        lnusertemp
Source Path                   /usr/libexec/kde4/lnusertemp
Port                          <Неизвестно>
Host                          (removed)
Source RPM Packages           kdelibs-4.10.4-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-59.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-301.fc19.x86_64 #1 SMP Thu
                              Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-10 09:11:46 EEST
Last Seen                     2013-07-10 09:11:46 EEST
Local ID                      0dd51e76-04a0-4fb9-ba2c-99244299e9f9

Raw Audit Messages
type=AVC msg=audit(1373436706.309:398): avc:  denied  { create } for  pid=1044 comm="lnusertemp" name=".kde" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir


type=SYSCALL msg=audit(1373436706.309:398): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=7fff6cdc83a0 a1=1c0 a2=ffffffffffffff80 a3=3fd items=0 ppid=1018 pid=1044 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=lnusertemp exe=/usr/libexec/kde4/lnusertemp subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: lnusertemp,xdm_t,admin_home_t,dir,create

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport

Potential duplicate: bug 772325
Comment 1 Miroslav Grepl 2013-07-16 04:56:56 EDT

*** This bug has been marked as a duplicate of bug 772325 ***

Note You need to log in before you can comment on or make changes to this bug.