Bug 98442 - kernel upgrade problem - oprofile-0.4-44.i386.rpm
Summary: kernel upgrade problem - oprofile-0.4-44.i386.rpm
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-02 15:17 UTC by Van
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 15:41:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Van 2003-07-02 15:17:46 UTC
Description of problem: Since I try to installed standard java packagae j2sdk-
1.4.2. And for some compatibility issue with linux kernels before 2.4.20, I 
attempted to upgrade my current kernel-2.4.18-14 to the lastest update kernel-
2.4.20-18.8.i686 but it fails due to dependency problems, even with --force 
option. However, it's fine with kernel-2.4.18-27. Would you plz tell me why? I 
found out that kernel-2.4.20 is also of Redhat 9, does it have anything to do 
with it? Would it be ok to install redhat 9 kernel on top of redhat 8's ?


Version-Release number of selected component (if applicable):


How reproducible:
I basically get the same error of failed dependency everytime I tried 
installing it. Also, the md5 check isn't good regardless of where I get the 
kernel-2.4.20-18.8.i686.rpm file. In fact, I got couple of copies from mirror 
of uw-madison and of redhat too.

Steps to Reproduce:
1. rpm -K kernel-2.4.20-18.8.i686.rpm -> NO KEY
2. rpm -ivh --force kernel-2.4.20-18.8.i686.rpm -> Failed Dependency
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Alan Cox 2003-07-05 13:07:24 UTC
Please provide the exact messages printed


Comment 2 Van 2003-07-05 21:20:26 UTC
 Sorry I didn't write down the error messages before, but it has to do with 
the dependency of oprofile and kernel files, and I managed to successfully 
update to kernel-2.4.20-8 by removing oprofile.
  However, I got another problem: without oprofile file, I don't seem to use 
mknode or anything involving sys files. So, I try to install oprofile-0.4-
44.i386.rpm, but it shows me the following messages ( I have no clue now ):

warning: oprofile-0.4-44.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing              ##########################################[100%]
cannot handle file "libc.so.6" with TLS data

 Would you plz tell me what's wrong with it, and how to fix it? Appreciate it!


Comment 3 Bugzilla owner 2004-09-30 15:41:14 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.