Bug 984428 - Serbian glyphs need improvement
Summary: Serbian glyphs need improvement
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-15 08:29 UTC by Alessandro Ceschini
Modified: 2013-08-25 22:57 UTC (History)
4 users (show)

Fixed In Version: liberation-fonts-1.07.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-25 22:57:01 UTC


Attachments (Terms of Use)
BE, PE, GE, DE, TE, SHA (36.00 KB, image/svg+xml)
2013-07-15 08:30 UTC, Alessandro Ceschini
no flags Details
Liberation Serbian Glyphs Test (124.48 KB, application/pdf)
2013-07-29 11:56 UTC, Alessandro Ceschini
no flags Details

Description Alessandro Ceschini 2013-07-15 08:29:09 UTC
Hello everybody,

This is a follow-up to bug 657849, concerning Serbian localised glyphs.

The issues are as following:

1) Serbian Italic TE has an en-dash above instead of the expected em-dash.
2) Serbian Regular/Italic BE is identical to Greek DELTA, which is bad, the tail above shouldn't be descending like in Greek DELTA but rather straight.
3) optional shape for Italic U+0448 CYRILLIC SMALL LETTER SHA, glyph shape is  like a Serbian Italic TE, but with an em-dash UNDERNEATH, instead of above.

The image I attached shows the expected glyph shapes, the three columns show respectively: Russian upright forms, Russian italic forms and Serbian italic forms; the letter are respectively: BE, PE, GE, DE, TE, SHA

Regards,

Comment 1 Alessandro Ceschini 2013-07-15 08:30:12 UTC
Created attachment 773598 [details]
BE, PE, GE, DE, TE, SHA

Comment 2 Pravin Satpute 2013-07-17 05:43:33 UTC
Thanks for reporting this bug. I am working on Liberation fonts this and next week. Hoping to resolve this bug soon.

Comment 3 Pravin Satpute 2013-07-24 11:51:17 UTC
(In reply to Alessandro Ceschini from comment #0)
> Hello everybody,
> 

> 2) Serbian Regular/Italic BE is identical to Greek DELTA, which is bad, the
> tail above shouldn't be descending like in Greek DELTA but rather straight.

http://pravins.fedorapeople.org/Serbian_BE.png does this make sense?

Comment 4 Alessandro Ceschini 2013-07-24 12:04:45 UTC
(In reply to Pravin Satpute from comment #3)
> (In reply to Alessandro Ceschini from comment #0)
> > Hello everybody,
> > 
> 
> > 2) Serbian Regular/Italic BE is identical to Greek DELTA, which is bad, the
> > tail above shouldn't be descending like in Greek DELTA but rather straight.
> 
> http://pravins.fedorapeople.org/Serbian_BE.png does this make sense?

Yes! Good job! :)

Comment 5 Pravin Satpute 2013-07-24 13:34:51 UTC
Thanks :)
Sans and Sans Narrow done. Will work tomorrow on Serif and Mono.

Comment 6 Pravin Satpute 2013-07-29 05:53:23 UTC
Serif and Mono is also done, will be available with the next release.

Comment 7 Alessandro Ceschini 2013-07-29 08:39:45 UTC
(In reply to Pravin Satpute from comment #6)
> Serif and Mono is also done, will be available with the next release.

Hello Pravin, where can I download the updated font so that I can test it?

Comment 8 Pravin Satpute 2013-07-29 08:53:36 UTC
Uploaded ttf version @ http://pravins.fedorapeople.org/export/ for testing.

Comment 9 Alessandro Ceschini 2013-07-29 09:16:36 UTC
Hello

1) the O-shaped main body of italic Serbian BE stil looks too similar to Greek DELTA, just make it like the upright style BE, which is OK.

2) I can't see the alternate glyph for SHA? Have you included it in the salt lookup?

Regards,

Comment 10 Alessandro Ceschini 2013-07-29 09:21:30 UTC
I'm sorry, 1) doesn't apply, the italic shape is all right, what was under my eyes was the former unupdated version, sorry.

Comment 11 Pravin Satpute 2013-07-29 09:29:38 UTC
Yeah, that i was about to say.

I can see Alternate SHA shape. it is only applicable for Italic, right?

Comment 12 Alessandro Ceschini 2013-07-29 09:33:30 UTC
OK, I can see it too, but the space between the dash and the main body is too little, it should be the same as in TE. The only thing that changes is the position of the dash, above or underneath.

Comment 13 Alessandro Ceschini 2013-07-29 09:33:55 UTC
Yes, only in Italic shape. OK, I can see it too, but the space between the dash and the main body is too little, it should be the same as in TE. The only thing that changes is the position of the dash, above or underneath.

Comment 14 Pravin Satpute 2013-07-29 09:47:17 UTC
Actually i tried to keep space between BAR and BASE glyph same between TE and SHA. 

I will again review it and update before release.

Comment 15 Alessandro Ceschini 2013-07-29 11:27:19 UTC
Liberation Serif Bold has no Serbian glyph for SMALL CYRILLIC BE

Comment 16 Alessandro Ceschini 2013-07-29 11:56:07 UTC
Created attachment 779820 [details]
Liberation Serbian Glyphs Test

I've uploaded an attachment with problematic glyphs highlighted in red.

General issues:
* With the exception of Sans Narrow, the dash above Italic PE is always too short, it needs to cover the main body in its entirety

Liberation Serif:
* Bold lacks localised glyph for BE
* Italic SHA: bar too close to the main body

Liberation Sans Narrow:
* Italic & Bold Italic PE protrudes a bit too much on the right
* Italic & Bold Italic GE dash above badly placed an too long

Liberation Mono:
* Bold lacks localised glyph for BE
* Italic & Bold Italic GE glyphs inappropriate, they look like latin small I with macron
* Italic & Bold Italic TE and SHA glyphs inappropriate for italic shape

Comment 17 Pravin Satpute 2013-07-30 09:22:55 UTC
(In reply to Alessandro Ceschini from comment #16)
> Created attachment 779820 [details]
> Liberation Serbian Glyphs Test
> 
> Liberation Mono:
> * Bold lacks localised glyph for BE
> * Italic & Bold Italic GE glyphs inappropriate, they look like latin small I
> with macron
> * Italic & Bold Italic TE and SHA glyphs inappropriate for italic shape

  This is how Liberation Mono is designed. 
  If still you need improvement please give me reference shapes, should it be like Sans?  But i will recommend using the existing shape as it follows Mono style.

  I have fixed all other issues. update fonts available @ http://pravins.fedorapeople.org/export/

Comment 18 Alessandro Ceschini 2013-07-30 12:08:19 UTC
(In reply to Pravin Satpute from comment #17)
> (In reply to Alessandro Ceschini from comment #16)
> > Created attachment 779820 [details]
> > Liberation Serbian Glyphs Test
> > 
> > Liberation Mono:
> > * Bold lacks localised glyph for BE
> > * Italic & Bold Italic GE glyphs inappropriate, they look like latin small I
> > with macron
> > * Italic & Bold Italic TE and SHA glyphs inappropriate for italic shape
> 
>   This is how Liberation Mono is designed. 
>   If still you need improvement please give me reference shapes, should it
> be like Sans?  But i will recommend using the existing shape as it follows
> Mono style.
> 
>   I have fixed all other issues. update fonts available @
> http://pravins.fedorapeople.org/export/

OK, but so, Mono glyphs for PE and perhpas even DE aren't appropriate for Mono style, they look too "serified", do you get my drift?

I'm going to test the new version and report as soon as possible.

Comment 19 Alessandro Ceschini 2013-07-30 12:20:00 UTC
My comments about the new version:

* The space between the main body of Italic & Bold Italic GE, PE, TE, and SHA and the bar is significantly shorter in Sans as compared to Serif. Is it intended?

* The bar above Italic & Bold Italic Sans Narrow GE is too long.

Other issues have been fixed. For the question of glyphs in Mono, see comment above.

Comment 20 Pravin Satpute 2013-07-30 12:28:24 UTC
* We can follow same height as used in Serif, will that work?

* Yeah in Sans Narrow that bar is too long, i just used macron glyph, i will make it shorter.

* I will improve mono shapes as well, will make is same as in Sans, hope so that will work.

Comment 21 Alessandro Ceschini 2013-07-30 12:40:09 UTC
1) OK
2) OK
3) I thought you deemed it inappropriate, have you changed you mind now? Why?

Comment 22 Pravin Satpute 2013-07-31 06:23:20 UTC
I am not original designer of Liberation Mono so i am bit reluctant to do modifications in style itself. 

For Serbian we are mostly reusing already existing shapes of Mono, so i thought will follow that style.

But as your suggestion are Serbian specific, now i think we can follow that. Please provide me some reference so i can update it.

Other updated fonts are available @ http://pravins.fedorapeople.org/export/

Comment 23 Alessandro Ceschini 2013-07-31 16:33:09 UTC
Dear Pravin,

I'm afraid I won't be able to provide you with anything since other Mono fonts normally don't have specific italic shapes, but the advice I can give you is to make the glyphs more "squared", more like TE and SHA, DE and PE should be "de-serified", specifically PE should look more or less like TE, just without the central bar, but it doesn't.

I hope it helps you.

Comment 24 Pravin Satpute 2013-08-01 11:43:21 UTC
Yes, i will update Mono PE and DE shape may be tomorrow.

Comment 25 Pravin Satpute 2013-08-02 09:11:48 UTC
Updated Mono PE shape, cant do much in DE shape. Update fonts available @ http://pravins.fedorapeople.org/export/

Hoping this will help.

Comment 26 Alessandro Ceschini 2013-08-02 13:20:47 UTC
(In reply to Pravin Satpute from comment #25)
> Updated Mono PE shape, cant do much in DE shape. Update fonts available @
> http://pravins.fedorapeople.org/export/
> 
> Hoping this will help.

Hello Pravin,

I'm going to check as soon as possible, meanwhile I suggest you place the SHA glyph in the cv00 lookup, not salt, because salt is too generic, maybe other styles or glyphs get activated as well and this is unintended. In a word, treat it just as a character variant, not as part of an alternate STYLE.

Comment 27 Pravin Satpute 2013-08-05 06:53:09 UTC
Not understood. :(
When SHA alternate shape should occur?

When someone using Serbian locale, right?

let me know the test cases so i can tweak it according to requirement.

Comment 28 Alessandro Ceschini 2013-08-05 09:57:41 UTC
Yes, using Serbian locale, but locl+salt is too generic, it could involve other variants, maybe also in the Latin range, while locl+cv00 is straightforward and implies no other variants, just the intended one.

Comment 29 Alessandro Ceschini 2013-08-05 10:04:37 UTC
I've just tested the glyphs and everything seems all right now, but Mono Italic & Bold Italic DE still doesn't convince me, it's too "serified" for me.

Comment 30 Pravin Satpute 2013-08-12 13:08:12 UTC
(In reply to Alessandro Ceschini from comment #28)
> Yes, using Serbian locale, but locl+salt is too generic, it could involve
> other variants, maybe also in the Latin range, while locl+cv00 is
> straightforward and implies no other variants, just the intended one.

Do you mean to use different Open type feature for this?

Sorry but still i am not clear on this, can you provide any reference for this? patch will be very helpful.

I will work on Mono DE and do release this week.

Comment 31 Alessandro Ceschini 2013-08-14 17:40:08 UTC
The feature is called cvxx in OpenType (xx stands for numbers from 00 to 99).

Comment 32 Pravin Satpute 2013-08-21 11:01:30 UTC
Hi Alessandro,

   Still not understanding both things :)

   Mono Italic and Bold Italic "DE" shape is same like Sans, dunno not getting your view clearly. Hoping you are talking about U+0434 only.

   For CV-xx i am looking for reference implementation but did not found any example yet.

   I think its time to do next release of Liberation fonts, might be you can report specific bugs for above issues and lets tackle it there separately?  and close these long standing bugs :)

Comment 33 Alessandro Ceschini 2013-08-21 11:50:50 UTC
Hello Pravin,

That's the problem: Mono and Sans are supposed to possess a different set of glyph aren't they? The fact that the glyphs for DE are identical in Mono and Sans is no good to me, I think this is understandable.

For information about character variants see here:
http://www.microsoft.com/typography/otspec/features_ae.htm

Then go to: "Tag: 'cv01' - 'cv99'"

Tell me if you want to report these two issues in another or two other bug reports and then close this one.

Bye

Comment 34 Pravin Satpute 2013-08-22 05:37:43 UTC
(In reply to Alessandro Ceschini from comment #33)
> Hello Pravin,
> 
> That's the problem: Mono and Sans are supposed to possess a different set of
> glyph aren't they? 

No, only difference between Mono and Sans is Mono is mono-width and Sans does not have that restriction either way both are same.

Yes, what you says is applicable to Sans and Serif fonts.

>The fact that the glyphs for DE are identical in Mono and
> Sans is no good to me, I think this is understandable.

Problem is i am not understanding what changes do you look in DE Mono shape, so not clear, if you can draw it on paper and scan it may be i can give better try. :)

> 
> For information about character variants see here:
> http://www.microsoft.com/typography/otspec/features_ae.htm
> 
> Then go to: "Tag: 'cv01' - 'cv99'"
> 
> Tell me if you want to report these two issues in another or two other bug
> reports and then close this one.

Yeah, i think different bugs will be good, i want to do release of Liberation and will looks for remaining bugs is next release.

Comment 35 Alessandro Ceschini 2013-08-22 10:52:35 UTC
If you say there's no difference between the glyphs, just in width between Sans and Mono, there's no need to change the glyph. By the way, I was wondering: wasn't Mono supposed not to have italic glyphs? That's what normally happens in other fonts, I don't know about your particular policy.

Comment 36 Alessandro Ceschini 2013-08-22 10:54:01 UTC
As far as the character variant is concerned, it's a wish, not a bug. Should I open a new bug report for it anyway?

Comment 37 Pravin Satpute 2013-08-22 11:01:37 UTC
No, Mono means Mono width, it is specifically required in terminal where fixed grid structure creates need of mono-width font family. 

We can have Mono serif family as well. Ok, in that case we will not consider this as well bug.

Don't create bug for Variant, i will add it in todo list.

I am happy to do next release now. :)

Comment 38 Alessandro Ceschini 2013-08-22 11:10:56 UTC
I said so because usually Mono fonts are designed in a Courier style without italic, just slanted typefaces.

OK, so, if you need my help, you know where to contact me.

Good job anyway! ;)

Comment 39 Fedora Update System 2013-08-23 08:42:39 UTC
liberation-fonts-1.07.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.3-1.fc19

Comment 40 Fedora Update System 2013-08-24 00:02:34 UTC
Package liberation-fonts-1.07.3-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.3-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15235/liberation-fonts-1.07.3-1.fc19
then log in and leave karma (feedback).

Comment 41 Fedora Update System 2013-08-25 22:57:01 UTC
liberation-fonts-1.07.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.