Bug 984468 - texlive-tetex-bin should require texlive-tetex.
texlive-tetex-bin should require texlive-tetex.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 06:20 EDT by Parag Nemade
Modified: 2014-06-27 10:20 EDT (History)
5 users (show)

See Also:
Fixed In Version: texlive-2013-3.20131021_r31961.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 03:02:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-07-15 06:20:55 EDT
Description of problem:
$sudo yum install tex-fonts-hebrew
<snip>
Running transaction
  Installing : 3:texlive-tetex-bin-svn29741.0-0.1.20130608_r30832.fc19.noarch                                                                                               1/2 
  Installing : tex-fonts-hebrew-0.1-20.fc19.noarch                                                                                                                          2/2 
/var/tmp/rpm-tmp.5e2Cgc: line 2: /usr/bin/texconfig-sys: No such file or directory
/var/tmp/rpm-tmp.5e2Cgc: line 4: /usr/bin/updmap-sys: No such file or directory
warning: %post(tex-fonts-hebrew-0.1-20.fc19.noarch) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package tex-fonts-hebrew-0.1-20.fc19.noarch
  Verifying  : 3:texlive-tetex-bin-svn29741.0-0.1.20130608_r30832.fc19.noarch                                                                                               1/2 
  Verifying  : tex-fonts-hebrew-0.1-20.fc19.noarch                      

Version-Release number of selected component (if applicable):
tex-fonts-hebrew-0.1-20.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1.just install this package on fresh f19 installed
2.
3.

Actual results:
scriptlet failure

Expected results:
should not fail scriptlet

Additional info:
Comment 1 Dan Kenigsberg 2013-07-15 15:41:45 EDT
Do you have an idea how did /usr/bin/texconfig-sys gone missing when the spec has

 Requires(post): /usr/bin/texhash /usr/bin/updmap-sys /usr/bin/texconfig-sys
Comment 2 Parag Nemade 2013-07-16 00:52:27 EDT
I first thought texlive-tetex-bin should requires texlive-tetex but then found this package if adds just 
Requires: texlive-tetex
then it will pull required packages as well.

But, even after that scriptlet failed. Then I find texlive-texconfig should requires texlive-texconfig-bin but its already in texlive package so better we add following in spec file.
Requires: texlive-texconfig

Built new tex-fonts-hebrew and tried to install but it failed again on %post scriptlets

----------------------------------------------------------------------------
About you question,The real files are
lrwxrwxrwx. 1 root root  8 Jul 16 10:11 /usr/bin/texhash -> mktexlsr
lrwxrwxrwx. 1 root root 62 Jul 16 10:11 /usr/bin/texconfig-sys -> /usr/share/texlive/texmf-dist/scripts/texlive/texconfig-sys.sh
lrwxrwxrwx. 1 root root 59 Jul 16 10:11 /usr/bin/updmap-sys -> /usr/share/texlive/texmf-dist/scripts/texlive/updmap-sys.sh

and these are missing due to what found above and should be added to spec as
Requires: texlive-tetex
Requires: texlive-texconfig
----------------------------------------------------------------------------

Not sure how this new scriptlet failure be fixed
  Installing : tex-fonts-hebrew-0.1-20.fc19.noarch                                                                                                                        12/12 
updmap: generated map otf-noEmbed.map (from otf-@kanjiEmbed@.map) does not exists, not activating it!
updmap: generated map ptex-noEmbed.map (from ptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating it!
updmap: generated map otf-up-noEmbed.map (from otf-up-@kanjiEmbed@.map) does not exists, not activating it!
updmap: generated map uptex-noEmbed.map (from uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating it!

ERROR:  The following map file(s) couldn't be found:
	morisawa.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
	otf-cktx.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)

	Did you run mktexlsr?

	You can disable non-existent map entries using the option
	  --syncwithtrees.

warning: %post(tex-fonts-hebrew-0.1-20.fc19.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package tex-fonts-hebrew-0.1-20.fc19.noarch
  Installing : tex-fonts-hebrew-0.1-20.fc19.noarch                                                                                                                        12/12 
updmap: generated map otf-noEmbed.map (from otf-@kanjiEmbed@.map) does not exists, not activating it!
updmap: generated map ptex-noEmbed.map (from ptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating it!
updmap: generated map otf-up-noEmbed.map (from otf-up-@kanjiEmbed@.map) does not exists, not activating it!
updmap: generated map uptex-noEmbed.map (from uptex-@kanjiEmbed@@kanjiVariant@.map) does not exists, not activating it!

ERROR:  The following map file(s) couldn't be found:
	morisawa.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)
	otf-cktx.map (in /usr/share/texlive/texmf-config/web2c/updmap.cfg)

	Did you run mktexlsr?

	You can disable non-existent map entries using the option
	  --syncwithtrees.

warning: %post(tex-fonts-hebrew-0.1-20.fc19.noarch) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package tex-fonts-hebrew-0.1-20.fc19.noarch
Comment 3 Dan Kenigsberg 2013-09-25 18:26:13 EDT
Sorry, I do not follow. tex-fonts-hebrew has a Requires(post) for the executable /usr/bin/texhash. If texhash cannot be run at this point, then it's a bug in its package texlive-kpathsea-bin.

I see another (similar) problem, though: the scriptlet complains about

 /usr/bin/texconfig-sys: No such file or directory

even though /usr/bin/texconfig-sys is pulled by texlive-tetex-bin. However, this is a broken soft link to /usr/share/texlive/texmf-dist/scripts/texlive/texconfig-sys.sh which is supplied by the not-installed texlive-tetex.

Bottom line - texlive-tetex-bin should require texlive-tetex.
Comment 4 Fedora Update System 2013-10-17 06:55:07 EDT
texlive-2013-1.20131014_r31898.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/texlive-2013-1.20131014_r31898.fc20
Comment 5 Fedora Update System 2013-10-17 06:57:53 EDT
texlive-2013-1.20131014_r31898.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/texlive-2013-1.20131014_r31898.fc19
Comment 6 Fedora Update System 2013-10-17 16:25:47 EDT
Package texlive-2013-1.20131014_r31898.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing texlive-2013-1.20131014_r31898.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19153/texlive-2013-1.20131014_r31898.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-11-10 03:02:57 EST
texlive-2013-3.20131021_r31961.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.