Bug 984537 - regression in gtk_text_ functions
regression in gtk_text_ functions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
19
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 09:05 EDT by Karel Srot
Modified: 2013-07-15 23:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 984539 (view as bug list)
Environment:
Last Closed: 2013-07-15 23:33:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
standalone reproducer for gtk_text_iter_starts_word() function (4.69 KB, text/x-csrc)
2013-07-15 09:07 EDT, Karel Srot
no flags Details

  None (edit)
Description Karel Srot 2013-07-15 09:05:46 EDT
Description of problem:

There are several failures in LSB test suite that were not present in Fedora 18 and are related to text_iter_* functions, for example:

---------------------------------------

/tests/functions/GtkTextIter/GtkTextIter 234 	failed 	
Message from the test:
test case: /opt/lsb/test/desktop/gtkvts/tet_tmp_dir/02926aa/tests/functions/GtkTextIter/GtkTextIter, TP number: 234 
GtkTextIter.c, line 14345: 
gtk_text_starts_word () returned not 1 incorrectly, line = 'word1word2 word3', pos = 4

or

Message from the test:
test case: /opt/lsb/test/desktop/gtkvts/tet_tmp_dir/02926aa/tests/functions/GtkTextIter/GtkTextIter, TP number: 340 
GtkTextIter.c, line 18892: 
gtk_text_ends_word () returned not 1 incorrectly, line = 'word1word2 word3', pos = 4

Message from the test:
test case: /opt/lsb/test/desktop/gtkvts/tet_tmp_dir/02926aa/tests/functions/GtkTextIter/GtkTextIter, TP number: 951 
GtkTextIter.c, line 53871: 
'gtk_text_iter_backward_word_start' moved iterator incorrectly
'Word1 Word2'
iter = (0, 0), should be (0, 4)

Message from the test:
test case: /opt/lsb/test/desktop/gtkvts/tet_tmp_dir/02926aa/tests/functions/GtkTextIter/GtkTextIter, TP number: 974 
GtkTextIter.c, line 55239: 
'gtk_text_iter_forward_word_end' moved iterator incorrectly
'Word 1.
Word2'
iter = (1, 5), should be (1, 4)

Message from the test:
test case: /opt/lsb/test/desktop/gtkvts/tet_tmp_dir/02926aa/tests/functions/GtkTextIter/GtkTextIter, TP number: 991 
GtkTextIter.c, line 56265: 
'gtk_text_iter_forward_word_ends' moved iterator incorrectly
'Word 1, Word2?! Word3'
count = 5, iter = (0, 21), should be (0, 20)

--------------------------------------

Actually this is a regression between pango-1.34.0-1 and pango-1.34.1-1.
Comment 1 Karel Srot 2013-07-15 09:07:21 EDT
Created attachment 773727 [details]
standalone reproducer for gtk_text_iter_starts_word() function

as an example I am adding a standalone reproducer for the gtk_text_iter_starts_word() function.

# ./a.out | grep FAIL
FAIL: gtk_text_starts_word () returned not 1 incorrectly, line = 'word1word2 word3', pos = 4
FAIL: gtk_text_starts_word () returned not 1 incorrectly, line = 'word1word2 word3', pos = 5
FAIL: gtk_text_starts_word () returned not 1 incorrectly, line = 'word1_word2 word3', pos = 4
Comment 2 Akira TAGOH 2013-07-15 23:33:20 EDT
This behavior was introduced by this change:
https://git.gnome.org/browse/pango/commit/?id=1aeb5c840e25a7d8538f701659d77dcd7b3a8444

According to the commit log, this change was needed to meet Unicode 6.2 specs and the previous behavior was wrong. so this is not a bug. please fix the test case instead.

Note You need to log in before you can comment on or make changes to this bug.