Bug 984583 - mysqld_safe is denied to execute hostname
mysqld_safe is denied to execute hostname
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.9
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 09:54 EDT by Karel Volný
Modified: 2013-09-30 18:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 18:26:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2013-07-15 09:54:12 EDT
Description of problem:
Trying to run the test for bug #462534 I'm getting AVCs.

Version-Release number of selected component (if applicable):
mysql51-mysql-server-5.1.69-7.el5

How reproducible:
always

Steps to Reproduce:
1. tail -f /var/log/audit/audit.log
2. run the test

Actual results:
type=AVC msg=audit(1373895562.116:306119): avc:  denied  { execute } for  pid=19472 comm="mysqld_safe" name="hostname" dev=sda2 ino=28377168 scontext=root:system_r:mysqld_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file                                                                                                                 
type=SYSCALL msg=audit(1373895562.116:306119): arch=40000003 syscall=11 success=no exit=-13 a0=8c4cb10 a1=8c4eac8 a2=8c4e1f8 a3=40 items=0 ppid=19423 pid=19472 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=34336 comm="mysqld_safe" exe="/bin/bash" subj=root:system_r:mysqld_t:s0 key=(null)                            
type=AVC msg=audit(1373895562.116:306120): avc:  denied  { getattr } for  pid=19472 comm="mysqld_safe" path="/bin/hostname" dev=sda2 ino=28377168 scontext=root:system_r:mysqld_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file                                                                                                            
type=SYSCALL msg=audit(1373895562.116:306120): arch=40000003 syscall=195 success=no exit=-13 a0=8c4cb10 a1=bfabb710 a2=7cdff4 a3=40 items=0 ppid=19423 pid=19472 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=34336 comm="mysqld_safe" exe="/bin/bash" subj=root:system_r:mysqld_t:s0 key=(null)                           
type=AVC msg=audit(1373895562.116:306121): avc:  denied  { getattr } for  pid=19472 comm="mysqld_safe" path="/bin/hostname" dev=sda2 ino=28377168 scontext=root:system_r:mysqld_t:s0 tcontext=system_u:object_r:hostname_exec_t:s0 tclass=file                                                                                                            
type=SYSCALL msg=audit(1373895562.116:306121): arch=40000003 syscall=195 success=no exit=-13 a0=8c4cb10 a1=bfabb610 a2=7cdff4 a3=8c4cb10 items=0 ppid=19423 pid=19472 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts2 ses=34336 comm="mysqld_safe" exe="/bin/bash" subj=root:system_r:mysqld_t:s0 key=(null)

Expected results:
(no errors)

Additional info:
Comment 3 RHEL Product and Program Management 2013-07-16 10:24:03 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 errata-xmlrpc 2013-09-30 18:26:08 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1312.html

Note You need to log in before you can comment on or make changes to this bug.