Bug 984611 - RFE: delete/dump auditing information from the _log tables
RFE: delete/dump auditing information from the _log tables
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Grant Gainey
Dimitar Yordanov
:
Depends On:
Blocks: sat560-blockers sat560-misc 993254
  Show dependency treegraph
 
Reported: 2013-07-15 10:32 EDT by Tomas Lestach
Modified: 2013-10-01 17:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-utils2.0.2-11-sat
Doc Type: Release Note
Doc Text:
Database changes from predefined tables are logged by the Satellite auditing feature. In time, the logging data could potentially grow too big and take up excessive disk space in the Satellite database. A script has been created to enable Satellite to purge the audit-log tables on a user set date.
Story Points: ---
Clone Of:
: 993254 (view as bug list)
Environment:
Last Closed: 2013-10-01 17:26:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2013-07-15 10:32:46 EDT
Description of problem:
We've introduced the auditing feature within the Bug 871711. We log DB changes of predefined tables.

We need a mechanism, that would purge the DB logging data, so the logging information do not grow too much.
Comment 1 Grant Gainey 2013-08-05 13:57:32 EDT
249fe86e5cb129bdb3e819de75e97f0b1c2eeced
Comment 2 Tomas Lestach 2013-08-12 04:55:01 EDT
Grant, would you add a Spacewalk commit to the BZ as well?
Comment 3 Grant Gainey 2013-08-12 07:47:21 EDT
SW commit 9868543d14407e287d65edcc5fa52a6141f004ab
Comment 7 Grant Gainey 2013-09-11 15:23:23 EDT
Fixes:
SW abc0e9ab27087acc3f0960becf934f40c589ee67 spacewalk-utils-2.1.15-1
SAT cb45de398aa9915d4fcf91b8f548e23d0d41721a
Comment 14 Clifford Perry 2013-10-01 17:26:13 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.