Bug 98462 - bonding TLB load sharing fails under heavy UDP Tx stress
bonding TLB load sharing fails under heavy UDP Tx stress
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
http://sourceforge.net/projects/bonding/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-02 13:46 EDT by Need Real Name
Modified: 2013-07-02 22:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.4.21-1.1931.2.349.2.2.ent
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 09:54:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-02 13:46:34 EDT
Description of problem:
When running very heavy UDP Tx stress traffic with 10/100 adapters, load-
sharing collapses to only one slave after a few seconds. Caused by a 
unsigned/signed cast error in the TLB code.

Version-Release number of selected component (if applicable):
kernel-2.4.20-1.1931.2.231.2.11.ent

How reproducible:
Configure a bond team with only 10/100 adapters and run very heavy UDP Tx 
stress traffic to many clients. Monitor Tx/Rx activity of the slaves.

Steps to Reproduce:
1. insmod bonding mode=5
2. ifconfig bond0 <ip-addr>
3. ifenslave bond0 eth0 eth1 eth2
4. start stress application (e.g iperf, netperf, etc.)
    
Actual results:
After a few seconds only one slave takes part of load sharing while others stay 
idle. Traffic may pass from slave to slave at 10 sec. intervals (re-balance 
timeout).

Expected results:
All slaves continuously take part of the load sharing.

Additional info:
A bug fix patch was sent by me on June 26th to bond-devel, linux-net and linux-
netdev lists. It was already accepted by Jeff Garzik into his net-drivers-2.4 
BK tree.
Comment 1 Larry Troan 2003-07-16 09:51:59 EDT
ISSUE TRACKER 25886 opened as sev 1
Comment 2 Rik van Riel 2003-07-16 09:57:07 EDT
Jeff, does Taroon already have the patch for this or is it still in your queue ?
Comment 3 Need Real Name 2003-07-23 13:11:08 EDT
Appears to be fix implemented in RHEL 3 B1 candidate kernel (version 2.4.21-
1.1931.2.349.2.2.ent).

Note You need to log in before you can comment on or make changes to this bug.