This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984625 - RFE: cannot create a volume under a specific tenant using the keystone default admin user
RFE: cannot create a volume under a specific tenant using the keystone defaul...
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: 5.0 (RHEL 7)
Assigned To: Eric Harney
Dafna Ron
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 10:54 EDT by Dafna Ron
Modified: 2016-04-26 20:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Allow admin to create volumes owned by specified tenant Reason: Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 02:51:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1262597 None None None Never

  None (edit)
Description Dafna Ron 2013-07-15 10:54:07 EDT
Description of problem:

I wanted to create a volume for a different tenant by logging in with the keystone admin user and we do not have a --tenant tag in create 

I think that since admin user can create a tenanat, a user and assign permissions there is no reason why the same user cannot create an object and assign it to a specific tenant. 

Version-Release number of selected component (if applicable):

openstack-cinder-2013.1.2-3.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a volume using admin user
2. 
3.

Actual results:

the volume is created only under the admin tenant and we have no way of creating a volume for a specific tenant using the admin user. 

Expected results:

we should be able to create a volume for a tenant

Additional info:
Comment 1 Eric Harney 2013-09-17 14:30:51 EDT
Are there any OpenStack operations that behave this way?  Creating VMs for tenants, creating images for tenants, etc.?
Comment 2 Dafna Ron 2013-11-21 10:53:11 EST
well, we can for images since glance help image-create shows: 
 --owner <TENANT_ID>   Tenant who should own image.

Instances run under a specific zone and I think that since we run them from a specific image that they will automatically be assigned to a tenant. 

since volume is an object we can attach or boot to an instance I think that we should be able to create it with --owner
Comment 3 Eric Harney 2013-12-10 15:15:23 EST
Havana / RHOS 4 now allows transfer of volumes from one owner to another, which I think enables the desired use case here:  admin creates a volume, initiates a volume transfer, provides tenant/user with the credentials needed to accept that transfer.

I would suggest that any further requests around this be handled upstream rather than here as I don't think there is a strong argument for adding this feature in the near future with transfer present in Havana.
Comment 4 Ayal Baron 2013-12-18 02:51:36 EST
Haim / Dafna, please file upstream.
Comment 5 Summer Long 2014-07-23 00:20:33 EDT
Eric, since nothing was done, have changed the requires_doc_text to -. Unless you think it should be marked as a 'Known Issue' and the doc text gives your workaround?
Comment 6 Eric Harney 2014-09-25 12:20:20 EDT
Agree w/ requires_doc_text- .

Note You need to log in before you can comment on or make changes to this bug.