Bug 984636 - horizon: we create a volume with a different user (under a different tenant) because session is not refreshed
horizon: we create a volume with a different user (under a different tenant) ...
Status: CLOSED DUPLICATE of bug 984486
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: RHOS Maint
Ami Jeain
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 11:26 EDT by Dafna Ron
Modified: 2015-06-04 17:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 07:33:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (12.10 KB, application/x-gzip)
2013-07-15 11:28 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2013-07-15 11:26:59 EDT
Description of problem:

I opened a browser with two tabs both for openstack dashboard. 
in one session I logged in with user admin -> moved to the volumes tab under project view
In the second session I logged in with a different user for a different tenant. 

I went back to the first session and pressed the create volume button and created a volume. 
the volume that was created was created with the second user on the second tenant (from the second tab)

Version-Release number of selected component (if applicable):

python-django-horizon-2013.1.2-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a tenant and a user with member permissions of the tenant
2. open firefox with two tabs pointing on openstack dashboard. 
3. in the first tab, log in as user admin -> in project view select volumes tab
4. in the second firefox tab, login with the new user
5. go back to the first firefox tab (one with admin login) -> create new volume 

Actual results:

we are creating a new volume but its created under the second tenant (the one we logged into in the second tab) and not under the admin tenant. 

Expected results:

if we ran over the cookies and are now logged in under a different user we should redirect to the main login page and not create a new object. 

Additional info:
Comment 1 Dafna Ron 2013-07-15 11:28:33 EDT
Created attachment 773815 [details]
logs
Comment 2 Julie Pichon 2013-07-17 07:33:25 EDT
Please, use 2 browsers to work as 2 different users at the same time.

*** This bug has been marked as a duplicate of bug 984486 ***

Note You need to log in before you can comment on or make changes to this bug.