Bug 984683 - token_format should be configurable
token_format should be configurable
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Getting_Started_Guide (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: async
: 3.0
Assigned To: Bruce Reeler
ecs-bugs
: Documentation, Triaged, ZStream
Depends On: 975050 975153
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 12:51 EDT by Stephen Gordon
Modified: 2016-04-26 09:40 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 978853
Environment:
Last Closed: 2014-01-16 19:33:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 33410 None None None Never
OpenStack gerrit 34694 None None None Never

  None (edit)
Comment 4 Martin Magr 2013-07-18 03:44:52 EDT
I will use Adam's explanation:

PKI tokens is the upstream default and has been since the start of the Grizzly development cycle.  However, the upstream Puppet package maintainers reversed this decsion when they ran into difficulty setting up the PKI certificaters.  Packstack uses the upstream puppet modules, and defaulted to UUID tokens.   We didn't discover this until late in the development cycle. At that point, all of the QA had been done on UUID tokens, and switching to PKI tokens was deemed too risky.

For the next release, the puppet modules have switched to using PKI tokens.
Comment 5 Bruce Reeler 2013-07-23 01:47:48 EDT
Added the new configuration key CONFIG_KEYSTONE_TOKEN_FORMAT to "Table 4.1. PackStack Configuration Keys" in "4.3. Running PackStack Non-interactively" saying it can be set to UUID of PKI, and although UUID is default, PKI is recommended as it will become default in future.

PackStack in interactive mode does not prompt for token format, so nothing added to instructions under "4.2. Running PackStack Interactively".
Comment 7 Bruce Reeler 2013-07-25 01:48:21 EDT
Added some further updates to "Table 4.1. PackStack Configuration Keys" in "4.3. Running PackStack Non-interactively", including correcting command argument formats.

Note You need to log in before you can comment on or make changes to this bug.