Bug 984695 - Installing Evolution in a non-Gnome desktop does not pull in dconf
Summary: Installing Evolution in a non-Gnome desktop does not pull in dconf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 19
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-15 17:29 UTC by Patrick O'Callaghan
Modified: 2013-07-26 00:22 UTC (History)
3 users (show)

Fixed In Version: gtkhtml3-4.6.6-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-26 00:22:17 UTC


Attachments (Terms of Use)

Description Patrick O'Callaghan 2013-07-15 17:29:54 UTC
Description of problem:
Evolution rpm package does not depend on dconf

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Install a KDE spin of Fedora (no default Gnome)
2.yum install evolution
3.dconf is not installed

Actual results:
Evolution fails to preserve certain settings between runs.

Expected results:
All non-default settings should be preserved.

Additional info:
Evolution gives no error message about failing to store settings info, nor is there anything in /var/log/messages. Installing dconf manually (using yum) fixes the issue.

Comment 1 Michael Schwendt 2013-07-15 17:47:40 UTC
Indeed, its backup-restore module executes the "dconf" tool (which would need to be added as an explicit dependency, because it's not automatically detected):

$ grep dconf * -R|grep \\.c:
modules/backup-restore/evolution-backup-tool.c:#define DCONF_DUMP_FILE_EDS "backup-restore-dconf-eds.ini"
modules/backup-restore/evolution-backup-tool.c:#define DCONF_DUMP_FILE_EVO "backup-restore-dconf-evo.ini"
modules/backup-restore/evolution-backup-tool.c:	run_cmd ("dconf dump " DCONF_PATH_EDS " >" EVOLUTION_DIR DCONF_DUMP_FILE_EDS);
modules/backup-restore/evolution-backup-tool.c:	run_cmd ("dconf dump " DCONF_PATH_EVO " >" EVOLUTION_DIR DCONF_DUMP_FILE_EVO);
modules/backup-restore/evolution-backup-tool.c:			run_cmd ("cat " EVOLUTION_DIR DCONF_DUMP_FILE_EDS " | dconf load " DCONF_PATH_EDS);
modules/backup-restore/evolution-backup-tool.c:			run_cmd ("cat " EVOLUTION_DIR DCONF_DUMP_FILE_EVO " | dconf load " DCONF_PATH_EVO);

Comment 2 Patrick O'Callaghan 2013-07-16 00:40:51 UTC
(In reply to Michael Schwendt from comment #1)
> Indeed, its backup-restore module executes the "dconf" tool (which would
> need to be added as an explicit dependency, because it's not automatically
> detected):

It's also wierd that no error is reported to the user when settings can't be saved, but that may be a separate Evolution or dconf bug.

Comment 3 Milan Crha 2013-07-16 04:56:24 UTC
Thanks for a bug report. I added the dependency into evolution-data-server, it talks to dconf too (it installs schema files there). The fix will be included in the next week's 3.8.4 update.

Comment 4 Patrick O'Callaghan 2013-07-16 09:51:48 UTC
(In reply to Milan Crha from comment #3)
> Thanks for a bug report. I added the dependency into evolution-data-server,
> it talks to dconf too (it installs schema files there). The fix will be
> included in the next week's 3.8.4 update.

Thanks Milan.

Comment 5 Milan Crha 2013-07-22 17:27:47 UTC
Matthew did the change before me for some reason. The release will be done shortly, during this week.

Comment 6 Fedora Update System 2013-07-23 19:36:53 UTC
gtkhtml3-4.6.6-1.fc19,evolution-ews-3.8.4-1.fc19,evolution-mapi-3.8.4-1.fc19,evolution-3.8.4-1.fc19,evolution-data-server-3.8.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gtkhtml3-4.6.6-1.fc19,evolution-ews-3.8.4-1.fc19,evolution-mapi-3.8.4-1.fc19,evolution-3.8.4-1.fc19,evolution-data-server-3.8.4-1.fc19

Comment 7 Fedora Update System 2013-07-25 00:46:48 UTC
Package gtkhtml3-4.6.6-1.fc19, evolution-ews-3.8.4-1.fc19, evolution-mapi-3.8.4-1.fc19, evolution-3.8.4-1.fc19, evolution-data-server-3.8.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtkhtml3-4.6.6-1.fc19 evolution-ews-3.8.4-1.fc19 evolution-mapi-3.8.4-1.fc19 evolution-3.8.4-1.fc19 evolution-data-server-3.8.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13574/gtkhtml3-4.6.6-1.fc19,evolution-ews-3.8.4-1.fc19,evolution-mapi-3.8.4-1.fc19,evolution-3.8.4-1.fc19,evolution-data-server-3.8.4-1.fc19
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-07-26 00:22:17 UTC
gtkhtml3-4.6.6-1.fc19, evolution-ews-3.8.4-1.fc19, evolution-mapi-3.8.4-1.fc19, evolution-3.8.4-1.fc19, evolution-data-server-3.8.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.