Bug 984696 - rt2800usb warning
rt2800usb warning
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-wireless-ralink
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 13:34 EDT by dev002
Modified: 2014-06-16 10:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.11.7-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 21:15:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dev002 2013-07-15 13:34:07 EDT
Description of problem:
kernel: [21223.011111] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 8 in queue 2
kernel: [21223.011163] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 8 in queue 2
kernel: [21223.011170] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 8 in queue 2
kernel: [21223.011204] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 9 in queue 2
kernel: [21223.019361] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 2
kernel: [21223.019415] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 2
kernel: [21223.019422] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 10 in queue 2
kernel: [21223.019451] phy0 -> rt2800usb_entry_txstatus_timeout: Warning - TX status timeout for entry 11 in queue 2
kernel: [21223.309278] phy0 -> rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
kernel: [21223.309390] phy0 -> rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
kernel: [21223.309512] phy0 -> rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
kernel: [21237.352727] phy0 -> rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. boot
2. configure hostapd
3. wait

Actual results:
warning

Expected results:
no warning

Additional info:
Bus 001 Device 003: ID 148f:2870 Ralink Technology, Corp. RT2870 Wireless Adapter

kernel-3.9.9-201.fc18.i686
Comment 1 Stanislaw Gruszka 2013-10-17 06:12:40 EDT
I posed fix for this bug here:
http://marc.info/?l=linux-wireless&m=138200448228863&w=2

Josh, please apply it.
Comment 2 Josh Boyer 2013-10-17 08:14:17 EDT
Fixed in git.  Thanks!
Comment 3 Justin M. Forbes 2013-10-18 17:16:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 4 Fedora Update System 2013-10-20 15:14:17 EDT
kernel-3.11.6-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.6-200.fc19
Comment 5 Fedora Update System 2013-10-20 15:15:45 EDT
kernel-3.11.6-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.6-100.fc18
Comment 6 Fedora Update System 2013-10-21 08:08:07 EDT
kernel-3.11.6-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.6-300.fc20
Comment 7 Fedora Update System 2013-10-21 14:28:10 EDT
Package kernel-3.11.6-300.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.6-300.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19611/kernel-3.11.6-300.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-22 01:39:40 EDT
kernel-3.11.6-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-10-22 23:36:12 EDT
kernel-3.11.6-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-11-02 15:25:02 EDT
kernel-3.11.6-101.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.6-101.fc18
Comment 11 Fedora Update System 2013-11-03 00:36:10 EDT
Package kernel-3.11.6-101.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.6-101.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20545/kernel-3.11.6-101.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-11-04 15:20:57 EST
kernel-3.11.7-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.7-100.fc18
Comment 13 Fedora Update System 2013-11-12 21:15:44 EST
kernel-3.11.7-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 dev002 2014-06-16 10:35:45 EDT
solved

Note You need to log in before you can comment on or make changes to this bug.