This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984756 - Label port 8554 for rtsp
Label port 8554 for rtsp
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 17:52 EDT by Michael Scherer
Modified: 2013-07-20 05:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-65.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:32:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to add another port for rtsp (1.17 KB, patch)
2013-07-15 17:52 EDT, Michael Scherer
no flags Details | Diff

  None (edit)
Description Michael Scherer 2013-07-15 17:52:06 EDT
Created attachment 773932 [details]
patch to add another port for rtsp

gnome-dvb-daemon try to bind to port 8554 on start, and this trigger
a rather unclear AVC since that port is not labelled.


While that port is not documented in the RFC, IANA has it
registered to rtsp-alt, and gnome-dvb daemon is streaming using rtsp, so this make sense to have the port labelled in the policy


Here is a patch to add the proper label.
Comment 1 Miroslav Grepl 2013-07-16 04:07:09 EDT
Thank you for the patch.
Comment 2 Fedora Update System 2013-07-17 07:52:33 EDT
selinux-policy-3.12.1-65.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-65.fc19
Comment 3 Fedora Update System 2013-07-18 01:59:50 EDT
Package selinux-policy-3.12.1-65.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-65.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13172/selinux-policy-3.12.1-65.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-07-20 05:32:57 EDT
selinux-policy-3.12.1-65.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.