Bug 984757 - TTY Keyboard Layout is not correct
TTY Keyboard Layout is not correct
Status: CLOSED DUPLICATE of bug 994180
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 17:53 EDT by Fabian
Modified: 2013-09-03 11:47 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 11:47:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian 2013-07-15 17:53:10 EDT
Description of problem:
After installing fedora19 the keyboard layout in the TTY (e.g. ctrl+alt+f2) does not match the actual layout as it was configured. vconsole.conf and localectl state that the correct layout is set.

Version-Release number of selected component (if applicable):


How reproducible:
install fedora 19 and go into any virtual console.

Steps to Reproduce:
1. install f19 and change keyboard layout to any specific layout like "de"
2. go into a virtual console by pressing ctrl+alt+fx (x=1,2,3,...)
3. try to type a character specificly avaiable on your keyboard (like ona qwerty the y which is a z in qertz)

Actual results:
wrong key was mapped.

Expected results:
proper keylayout

Additional info:
manually chaning it via:
'loadkeys de-nodeadkeys' solved it.
Comment 1 Harald Hoyer 2013-07-29 10:31:43 EDT
does updating the initramfs with the changed vconsole.conf fix the issue?
# dracut -f
Comment 2 thohai 2013-08-06 03:58:59 EDT
Hi Harald!

In my case (F19 x64 kernel 3.10.4) "dracut -f" does not help.

After reboot the qwerty keyboard is used although the /etc/vconsole.conf 
looks like this:
KEYMAP=de
FONT=latarcyrheb-sun16

As with Fabian: loadkeys temporarily solves the problem.
Comment 3 Matthieu Araman 2013-08-12 17:45:29 EDT
same pb here, with French keyboard

had to change the password via X to be able to login 

once logged, loadkeys fr works

I'm trying the dracut -f
Comment 4 Matthieu Araman 2013-08-12 17:50:20 EDT
after dracut -f and reboot, it's ok
very strange...
Comment 5 Harald Hoyer 2013-08-16 04:28:04 EDT
The root problem is, I think, that anaconda does the yum transaction (in which dracut creates the initramfs image) before writing /etc/vconsole.conf and /etc/locale.conf.

And the kernel command line may not contain the keyboard and language setting.
Comment 6 Matthieu Araman 2013-09-01 12:10:37 EDT
to give additional info, I upgraded from F16 to F19 with :
F16 to F17 via yum (using raid-1, preupgrade doesn't work with it) then just after
F17 to F19 via Fedup

So it looks like there's some missing thing when upgrading with fedup
Comment 7 David Shea 2013-09-03 11:47:44 EDT

*** This bug has been marked as a duplicate of bug 994180 ***

Note You need to log in before you can comment on or make changes to this bug.