Bug 984771 - In bug list, flags are not ordered correctly
Summary: In bug list, flags are not ordered correctly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List   
(Show other bugs)
Version: 4.4
Hardware: All All
unspecified
unspecified vote
Target Milestone: 4.4
Assignee: Simon Green
QA Contact: tools-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-15 23:35 UTC by Simon Green
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version: 4.4.1011
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-22 01:55:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 936275 None None None Never

Description Simon Green 2013-07-15 23:35:47 UTC
Description of problem:
In bug list, flags are not ordered correctly

Version-Release number of selected component (if applicable):
4.4-3.5

How reproducible:
always

Steps to Reproduce:
1. Do a query
2. Change columns to include flags

Actual results:
Flags seem to be ordered alphabetically. (eg bugzilla-4.4?, hss_devel_ack+, hss_pm_ack?, hss_qa_ack? )

Expected results:
Flags should be ordered according to the flag sort order (eg bugzilla-4.4?, hss_pm_ack?, hss_devel_ack+, hss_qa_ack? 

Additional info:

Comment 1 Simon Green 2013-07-23 23:27:15 UTC
Changing the estimate to five hours, since the solution needs to be database agnostic.

Comment 2 Simon Green 2013-09-04 06:50:25 UTC
SQLite: https://www.sqlite.org/lang_aggfunc.html
"The order of the concatenated elements is arbitrary."

Oracle: Someone can work on changing the PL/SQL if they wish

Postgres:
http://mssql-to-postgresql.blogspot.com.au/2007/12/cool-groupconcat.html
http://explainextended.com/2009/05/02/group_concat-in-postgresql-without-aggregate-functions/
(maybe others)

Original upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=552919

Comment 5 Simon Green 2013-11-05 08:09:42 UTC
It's easy for Postgres 9+ see http://stackoverflow.com/questions/2560946/postgresql-group-concat-equivalent

So I've written the change for Mysql and Pg 9+ and will test it tomorrow and submit it upstream. If someone wants to work on it for earlier versions of Pg or Oracle or Sqlite, they can. Otherwise the code will still work (just not be ordered).

Comment 9 Simon Green 2013-11-22 01:55:44 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon


Note You need to log in before you can comment on or make changes to this bug.