Bug 984772 - Bug: Chapter level topic titles do not override title specified in CSP maps.
Bug: Chapter level topic titles do not override title specified in CSP maps.
Status: CLOSED NOTABUG
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 20:01 EDT by Misha H. Ali
Modified: 2013-07-15 20:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 20:17:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-07-15 20:01:58 EDT
Not sure which component this pertains to.

I noticed that a section level title (which is also a topic) had the correct title in the topic properties but had some extra characters in the CSP Map entry. Tested as follows:

1. Edited Content Spec 20420 in the CCMS UI

2. Used the following Chapter and Topic level content:

Chapter: Setting up an annotations project [20331]
  Requirements [20332]

3. Added an a to the ends of both topic titles and saved in the CCMS UI:

Chapter: Setting up an annotations projecta [20331]
  Requirementsa [20332]

4. Waiting for docbuilder to refresh and viewed results:

***

1. Setting up an annotations projecta

    1.1. Requirements

***

So it looks like if we add new names in the CSP Map for normal topics, the DocBuilder overrides this with the name provided in the Topic Properties. If we do the same for Chapter level (and assuming Section and Part level topics as well, although I have not tested on them), it used the incorrect name from the CSP map and disregards the Topic Properties title.

Not sure if this is intentional to allow quick and easy chapter, section and part name changes or if it is a bug.
Comment 1 Lee Newson 2013-07-15 20:17:42 EDT
This was intentional, since we came up with multiple cases where the two may not align. The other part to remember is that you are only using the content of the topic as the front matter content, and not the actual topic itself as a whole. So the chapter title will always come from the spec, as it always has done in previous version.

There is an option (--strict-level-titles) in the csprocessor push/create/validate commands to ensure that the titles match, otherwise you'll notice in the push/create/validate logs that there is a warning that the titles don't match.

Note You need to log in before you can comment on or make changes to this bug.