This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 984789 - All artifacts have the same history
All artifacts have the same history
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: ---
Assigned To: Eric Wittmann
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-15 23:14 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (190.33 KB, image/png)
2013-07-15 23:14 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-07-15 23:14:14 EDT
Description of problem:

See attached screenshot - the history values are the same for every artifact. Is this canned data?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-07-15 23:14:48 EDT
Created attachment 774001 [details]
Screenshot
Comment 2 Eric Wittmann 2013-07-16 07:37:53 EDT
We have actually not yet implemented full versioning support yet, and what  you're seeing here is actually bleeding through from the HTML template used to build the dynamic page.  So yes, in a sense it's canned data (more like *can't* data, am I right?).

In any case, the latest version of the UI hides the History tab completely (due to the incompleteness of the feature).  

Note also that [XmlDocument] and "Derived from: Master Artifact 0" are also static (they have the same values for all artifacts).  In the most recent version the former is fixed and the latter was removed.

I feel we should not bother fixing these for Alpha, and they are already fixed for Beta.

Please advise (I don't see an alpha blocker tag anywhere).
Comment 3 Eric Wittmann 2013-08-26 09:36:14 EDT
Marking as modified - see previous comment.
Comment 4 Stefan Bunciak 2013-09-09 10:16:21 EDT
Verified in S-RAMP 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.