Bug 984792 - Wine Compilation error [NEEDINFO]
Wine Compilation error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: compat-gcc-34 (Show other bugs)
6.4
i386 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 00:07 EDT by Soohyun
Modified: 2014-11-18 16:34 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 16:34:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jakub: needinfo? (soohyun2222)


Attachments (Terms of Use)

  None (edit)
Description Soohyun 2013-07-16 00:07:44 EDT
Description of problem:
I got error when compiling some dll program. This was done during the wine installation process.

Version-Release number of selected component (if applicable):
Cent OS 6.4 & Wine 1.6-rc5

How reproducible:
Been getting this message since wine released its latest version rc5.
However, also changed chmod of /home/sol013/lib/ to readable.

Steps to Reproduce:
Get LoL installation script: winehq.org = app list - League of Legends and copy wget ... Install_LoL.sh and paste it in terminal.

Actual results:
When compiling, towards the end I get compiling error.
It is saying it could be Os or hardware problem and report it to this site.

Expected results:
Compilation w/o any error

Additional info:
This could be the indicator that my computer is unstable.
Been getting crashes in Linux...
This problem because I am using every slot of my memory and also have been downclocking my CPU (by 10MHz) to make it stable. 
However, also writing this issue because it could be a OS problem.
If you know any relationship between computer stability and comiling please let me know. Or if anyone having this issue please join in!
Comment 2 RHEL Product and Program Management 2013-10-13 19:22:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jakub Jelinek 2014-10-02 10:19:59 EDT
Can you reproduce it, always on the same file same compiler options same error?
If the compiler says it can't reproduce it, likely it is a hw issue.
If you can reproduceably trigger it, please attach preprocessed source and list all compiler options used to compile the source that triggers the compiler internal error.
Comment 5 Jeff Law 2014-11-18 16:34:22 EST
While we acknowledge that an internal-compiler-error is bad, we are not planning to update compat-gcc-34 to fix this issue.  While we certainly could fix this bug, policy is to minimize the amount of changes made to the compat-gcc packages.

We strongly recommend using the base system compiler or the DTS compilers.

Note You need to log in before you can comment on or make changes to this bug.