Bug 984836 - Error in yum error text - $20 instead of %20 in URL to report errors
Error in yum error text - $20 instead of %20 in URL to report errors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: PackageKit (Show other bugs)
6.4
All Linux
medium Severity low
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks: 1271696
  Show dependency treegraph
 
Reported: 2013-07-16 03:24 EDT by Kurt Seifried
Modified: 2016-05-10 20:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: PackageKit-0.5.8-26.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:35:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2013-07-16 03:24:34 EDT
Description of problem:

Run yum update on system with some conflicting RPMS

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 6.4 (Santiago)
yum-3.2.29-40.el6.noarch

How reproducible:

Always

Steps to Reproduce:
1. "yum update" on system with all rpms installed

Actual results:

ERROR with rpm_check_debug vs depsolve:
libndr-krb5pac.so.0()(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
libndr-krb5pac.so.0(NDR_KRB5PAC_0.0.1)(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
libndr.so.0()(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
libndr.so.0(NDR_0.0.1)(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
libsamba-util.so.0()(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
libsamba-util.so.0(SAMBA_UTIL_0.0.1)(64bit) is needed by sssd-1.9.2-82.7.el6_4.x86_64
Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Red$20Hat$20Enterprise$20Linux$206&component=yum

Expected results:

Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%206&component=yum
Comment 1 Zdeněk Pavlas 2013-07-16 04:07:51 EDT
The default bugtracker URL in RHEL is: 'https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%206&component=yum', and this dates back to RHEL-5.. (BZ 528738).  Are you sure it's not overriden in yum.conf?

$ grep bugtracker /usr/lib/python2.7/site-packages/yum/config.py
    bugtracker_url = Option('https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%206&component=yum')
$ grep bugtracker /etc/yum.conf 
<no match>
Comment 2 Kurt Seifried 2013-07-16 04:15:06 EDT
So do this, forcibly install samba-* and remove all samba4-*, and forcibly install  sssd, previous versions (so use yum downgrade or whatever as needed), then try a yum update via the GUI tool, voila. I cut and paste that error directly from the text box.
Comment 3 Karel Srot 2013-07-16 09:59:23 EDT
I can confirm the bug. yum itself has the correct url but it looks like gnome-packagekit (gpk-update-viewer) somehow substitues '%' with '$'.
Comment 4 Zdeněk Pavlas 2013-07-16 10:52:34 EDT
Packagekit is rewriting "%20" to "$20" (the markdown filter?).. reassigning.
Comment 6 Richard Hughes 2014-05-20 06:03:12 EDT
This is a PackageKit oddity. I can certainly fix it, but it only affects error messages so I don't think it's a huge priority.
Comment 7 Kurt Seifried 2014-05-30 15:43:34 EDT
(In reply to Richard Hughes from comment #6)
> This is a PackageKit oddity. I can certainly fix it, but it only affects
> error messages so I don't think it's a huge priority.

The problem is that error message is how people report errors to us, so this makes it much harder and there may be other problems that customers are frustrated about and not telling us because of this error. =(.
Comment 13 errata-xmlrpc 2016-05-10 20:35:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0914.html

Note You need to log in before you can comment on or make changes to this bug.