Bug 984849 - Runtime and checked exceptions are handled differently from auditors POV
Runtime and checked exceptions are handled differently from auditors POV
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 03:48 EDT by Jiri Pechanec
Modified: 2015-08-02 19:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 13:01:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (16.38 KB, application/x-compressed-tar)
2013-07-16 03:49 EDT, Jiri Pechanec
no flags Details

  None (edit)
Description Jiri Pechanec 2013-07-16 03:48:24 EDT
When a checked exception is thrown then it is handled by provider processor but when runtime exception is thrown it is handled by error processor. This can lead into different behaviour and introduce hard-to-find bugs.

An example is attached - see test OrderServiceTest. A service is called twice once throwing checked and once unchecked exception.

Diff files f1.txt and f2.txt in reproducer to see that different processors are in place.
Comment 1 Jiri Pechanec 2013-07-16 03:49:02 EDT
Created attachment 774055 [details]
Reproducer
Comment 2 Keith Babo 2013-08-02 10:37:58 EDT
The internal handling of these exceptions is different, so I would expect the audit behavior to be different as well.  Auditors are intended as low-level debugging tools and are tightly integrated with the bus behavior in SY.  User applications should use these sparingly and should not use them at all to influence runtime behavior.  ExchangeInterceptors, on the other hand, should be very predictable and can be used by end users in both test and runtime.

Note You need to log in before you can comment on or make changes to this bug.