Bug 984965 - cppcheck reveals new errors in 16->17 release
cppcheck reveals new errors in 16->17 release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logrotate (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Kaluža
Tomas Dolezal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 09:44 EDT by Tomas Dolezal
Modified: 2015-07-22 02:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: logrotate-3.7.8-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: When parsing "create" directive, logrotate incorrectly set maximum length of the "create" directive argument to 200, while it should have been set to 199 according to the size of buffer used to store the argument. Consequence: It has been possible to overflow the buffer when create directive's argument was longer than 199 characters. Fix: Parsing of "create" directive has been fixed to limit maximum argument length properly. Result: Parsing of long arguments of create directive works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:19:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-07-16 09:44:07 EDT
Description of problem:
cppcheck-diff reveals new errors in old->new SRPM test.

Version-Release number of selected component (if applicable):
logrotate-3.7.8-16.el6.src.rpm
logrotate-3.7.8-17.el6.src.rpm

How reproducible:
always

Steps to Reproduce:
$ cppcheck-diff.sh old.srpm new.srpm --lines

Actual results:
<snip file=output.diff>
-config.c@line 1067: Common realloc mistake: 'tabooExts' nulled but not freed upon failure [error]
+config.c@line 1078: Common realloc mistake: 'tabooExts' nulled but not freed upon failure [error]
+config.c@line 741: Width 200 given in format string (no. 1) is larger than destination buffer 'createOwner[200]', use %199s to prevent overflowing it. [error]
+config.c@line 741: Width 200 given in format string (no. 2) is larger than destination buffer 'createGroup[200]', use %199s to prevent overflowing it. [error]
</snip>

Expected results:
no new errors (better any) should be reported by diffing r:16 package to newer

Additional info:
Comment 4 RHEL Product and Program Management 2013-10-13 19:22:23 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 9 errata-xmlrpc 2015-07-22 02:19:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1293.html

Note You need to log in before you can comment on or make changes to this bug.