Bug 985052 - layout problems with very long lines
layout problems with very long lines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hunspell (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
https://sourceforge.net/p/hunspell/bu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 12:35 EDT by Orion Poplawski
Modified: 2013-08-12 14:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: hunspell-1.3.2-13.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:06:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test case (691 bytes, text/plain)
2013-07-24 10:35 EDT, Orion Poplawski
no flags Details
probable update of patch to apply again (2.92 KB, patch)
2013-07-24 10:36 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2013-07-16 12:35:10 EDT
Description of problem:

hunspell has layout problems with very long lines (also pointed out in the manpage)

There is an upstream bug (see url) with an old patch that no longer applies.  It would be great if this could be fixed.

Version-Release number of selected component (if applicable):
hunspell-1.3.2-10.fc18.x86_64
Comment 1 Caolan McNamara 2013-07-24 10:23:08 EDT
Seems the reason it doesn't apply is because I had a stab at the same problem in the past. How do I reproduce the remaining problem ?
Comment 2 Orion Poplawski 2013-07-24 10:35:46 EDT
Created attachment 777824 [details]
test case

Spell checking the attached with:

hunspell hunspell.test

at Toriumi the display is corrupted, e.g.:


        Toriumi         File: hunspell.test

chanisms acting below the surface.  In a recent study (Leka et al. 2013, Birch et al. 2013, Barnes et al. 2013), in addition
to a weak but significant helioseismic signature, a faint pre-emergence magnetic signature was found, detectable only through
 ensemble averages of over 100 targets.  It has also been reported recently that horizontal diverging flows have been detecte
Toriumi to the appearance of magnetic flux (Toriumi et al. 2012).

 0: Moratorium


See how "dectected" is chopped and Toriumi is placed on the far left corrupting that line.
Comment 3 Caolan McNamara 2013-07-24 10:36:30 EDT
Created attachment 777825 [details]
probable update of patch to apply again

here's the patch again tweaked to apply against HEAD
Comment 4 Orion Poplawski 2013-07-24 12:44:33 EDT
Looks good to me.  Thanks!
Comment 5 Fedora Update System 2013-07-25 04:50:47 EDT
hunspell-1.3.2-13.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/hunspell-1.3.2-13.fc19
Comment 6 Orion Poplawski 2013-07-25 15:42:11 EDT
Caolan - could we get an update for F18 as well?  Thanks!
Comment 7 Fedora Update System 2013-07-25 15:56:42 EDT
hunspell-1.3.2-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/hunspell-1.3.2-13.fc18
Comment 8 Fedora Update System 2013-07-25 20:37:28 EDT
Package hunspell-1.3.2-13.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hunspell-1.3.2-13.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13658/hunspell-1.3.2-13.fc19
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-07-27 21:06:08 EDT
hunspell-1.3.2-13.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-12 14:01:54 EDT
hunspell-1.3.2-13.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.