Bug 985068 - missing support for mate-screensaver
missing support for mate-screensaver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xdg-utils (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 13:23 EDT by Andre Gompel
Modified: 2013-10-09 21:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: xdg-utils-1.1.0-0.18.20131005git.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 07:37:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix for xdg-screensaver to support MATE desktop (5.53 KB, patch)
2013-10-05 14:22 EDT, Mansour Behabadi
no flags Details | Diff

  None (edit)
Description Andre Gompel 2013-07-16 13:23:01 EDT
Description of problem:
    This bug exist with MATE only, not when login as Gnome3

Version-Release number of selected component (if applicable):
Current, on Fedora 19

How reproducible: 
Solid

Steps to Reproduce:
  Just watch a video, using VLC, the display dims after a few minutes (may ten) , the power management is properly set.

2. Updated 
3.

Actual results:
   Display dims after a few minutes. Unlike Gnome3 which works OK.

Expected results:
   Display power management works exactly the same with MATE and Gnome3

Additional info:
   This bug was reported about two years ago, in Gnome 2, and then fixed.
   I suppose current MATE version uses an older Gnome 2 as base, so this bug is creeping up again.
Comment 1 Wolfgang Ulbrich 2013-07-16 14:58:19 EDT
(In reply to Andre Gompel from comment #0)

> Additional info:
>    This bug was reported about two years ago, in Gnome 2, and then fixed.
>    I suppose current MATE version uses an older Gnome 2 as base, so this bug
> is creeping up again.
Do you have a link?
Comment 2 Fedora Update System 2013-07-17 15:20:30 EDT
mate-screensaver-1.6.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-screensaver-1.6.0-2.fc18
Comment 3 Fedora Update System 2013-07-17 15:20:45 EDT
mate-screensaver-1.6.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-screensaver-1.6.0-2.fc19
Comment 4 Fedora Update System 2013-07-17 15:21:01 EDT
mate-screensaver-1.6.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-screensaver-1.6.0-2.fc17
Comment 5 Fedora Update System 2013-07-27 21:03:25 EDT
mate-screensaver-1.6.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-07-27 21:09:45 EDT
mate-screensaver-1.6.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-07-27 21:10:39 EDT
mate-screensaver-1.6.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Andre Gompel 2013-07-28 14:29:18 EDT
(In reply to Wolfgang Ulbrich from comment #1)
> (In reply to Andre Gompel from comment #0)
> 
> > Additional info:
> >    This bug was reported about two years ago, in Gnome 2, and then fixed.
> >    I suppose current MATE version uses an older Gnome 2 as base, so this bug
> > is creeping up again.
> Do you have a link?

Sorry I do not...
Comment 9 Andre Gompel 2013-07-28 14:31:10 EDT
In spite of the latest (Fedora 19 x86_64) updates, bug is still here, on July 28, 2013
A.G
Comment 10 Wolfgang Ulbrich 2013-07-28 16:34:07 EDT
I can confirm the issue in f19 and i have informed MATE upstream.
https://github.com/mate-desktop/mate-screensaver/issues/21
Comment 11 Mansour Behabadi 2013-10-05 11:43:17 EDT
Since VLC uses xdg-utils (xdg-screensaver in particular) to inhibit the screensaver, the issue is xdg-utils lack of support for MATE desktop (ie component on this bug should be changed to xdg-utils).

I have posted a patch to xdg-utils upstream [1] which is also available in my repo [2] to use for the time being.

[1] http://lists.freedesktop.org/archives/xdg/2013-October/012890.html
[2] https://github.com/oxplot/xdg-utils/commit/83358a12ccb60177b6698db33fb85176c5400fde
Comment 12 Mansour Behabadi 2013-10-05 12:41:13 EDT
Oops, I didn't patch everything necessary to make it work. Here's the second (and hopefully final) part:

http://lists.freedesktop.org/archives/xdg/2013-October/012891.html

https://github.com/oxplot/xdg-utils/commit/352efc1980859655c2b8644179ef3262a5b1cd9c
Comment 13 Wolfgang Ulbrich 2013-10-05 12:52:47 EDT
So, i need both patches to do a scratch build for testing?
If it works i will re-assigned this report to xdg-screensaver.
Than we should ask the maintainer to rebuild xdg-screensaver with the patch for fedora, so we don't have to wait for a new release.
I think it's better in this case you put both in one patch ;)
Also for your pull request.
Comment 14 Mansour Behabadi 2013-10-05 13:00:30 EDT
(In reply to Wolfgang Ulbrich from comment #13)
> So, i need both patches to do a scratch build for testing?

Yes. There is a xdg-screensaver and xdg-screensaver.in file (hence the two patches) and apparently the former is not used when installing it but it might have some use that I don't know of-anyway both are fixed now.

> If it works i will re-assigned this report to xdg-screensaver.
> Than we should ask the maintainer to rebuild xdg-screensaver with the patch
> for fedora, so we don't have to wait for a new release.
> I think it's better in this case you put both in one patch ;)
> Also for your pull request.

So, I wait for you to test it and then post the single patch here?
Comment 15 Wolfgang Ulbrich 2013-10-05 13:20:51 EDT
Ahh, i didn't look into the patches.
So, the second is patch 1 + extra?
I will build it soon an post a link here
Comment 16 Mansour Behabadi 2013-10-05 13:23:19 EDT
(In reply to Wolfgang Ulbrich from comment #15)
> Ahh, i didn't look into the patches.
> So, the second is patch 1 + extra?

Oh no, you were right the first time. The patches are mutually exclusive. You need both.
Comment 17 Wolfgang Ulbrich 2013-10-05 14:11:05 EDT
scratch build for testing.
http://koji.fedoraproject.org/koji/taskinfo?taskID=6027931

It works well, tested with mate-mplayer, vlc and smplayer.
So i would suggest update your pull request with a 2 in 1 patch and and attach it here in the report.
Than i will re-assigned the report and we should ask the maintainer for a official build.
Comment 18 Mansour Behabadi 2013-10-05 14:22:40 EDT
Created attachment 808175 [details]
fix for xdg-screensaver to support MATE desktop

This patch is against the upstream commit c96d7b00aca3da1b608fde5827d7fea8785b3cd3.
Comment 19 Wolfgang Ulbrich 2013-10-05 14:54:14 EDT
Dear maintainer,
It would be very helpful if you could test the patch and build a new xdg-utils release for rawhide/f20/f19/f18.

Thank you
Comment 20 Fedora Update System 2013-10-05 17:15:24 EDT
xdg-utils-1.1.0-0.18.20131005git.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xdg-utils-1.1.0-0.18.20131005git.fc20
Comment 21 Fedora Update System 2013-10-05 17:15:57 EDT
xdg-utils-1.1.0-0.18.20131005git.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xdg-utils-1.1.0-0.18.20131005git.fc19
Comment 22 Fedora Update System 2013-10-05 17:16:32 EDT
xdg-utils-1.1.0-0.18.20131005git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xdg-utils-1.1.0-0.18.20131005git.fc18
Comment 23 Fedora Update System 2013-10-06 01:31:04 EDT
Package xdg-utils-1.1.0-0.18.20131005git.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xdg-utils-1.1.0-0.18.20131005git.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18416/xdg-utils-1.1.0-0.18.20131005git.fc20
then log in and leave karma (feedback).
Comment 24 Fedora Update System 2013-10-08 07:37:51 EDT
xdg-utils-1.1.0-0.18.20131005git.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2013-10-09 10:12:33 EDT
xdg-utils-1.1.0-0.18.20131005git.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-10-09 21:00:29 EDT
xdg-utils-1.1.0-0.18.20131005git.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.