Bug 985072 - file fails to recognize systemd journal files (no entry in /etc/magic)
file fails to recognize systemd journal files (no entry in /etc/magic)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 13:41 EDT by Przemek Klosowski
Modified: 2013-08-25 18:55 EDT (History)
3 users (show)

See Also:
Fixed In Version: file-5.11-11.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-25 18:55:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Przemek Klosowski 2013-07-16 13:41:42 EDT
Description of problem:
'file' does not recognize systemd *.journal files because there is no definition for them in /etc/magic 


Version-Release number of selected component (if applicable):
all versions

How reproducible:
every time

Steps to Reproduce:
1. file   /var/log/journal/*/*journal

Actual results:
all files are reported as 'data'

Expected results:
they should be reported as 'systemd journal files'
Comment 1 Przemek Klosowski 2013-07-16 13:49:07 EDT
The simple fix is to add the following definition to /etc/magic or cause it to appear in /usr/share/misc/magic.mgc

0 string LPKSHHRH systemd journal file
Comment 2 Jan Kaluža 2013-07-17 02:58:57 EDT
Sent upstream: http://bugs.gw.com/view.php?id=266
Comment 3 Zbigniew Jędrzejewski-Szmek 2013-07-17 11:32:56 EDT
Already done in http://bugs.gw.com/view.php?id=258.
Comment 4 Fedora Update System 2013-08-22 03:57:02 EDT
file-5.11-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/file-5.11-11.fc19
Comment 5 Fedora Update System 2013-08-22 20:38:19 EDT
Package file-5.11-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing file-5.11-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15175/file-5.11-11.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-08-25 18:55:21 EDT
file-5.11-11.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.