Bug 985076 - Boot slow
Boot slow
Status: CLOSED DUPLICATE of bug 983688
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 13:54 EDT by Maarten
Modified: 2013-09-12 23:21 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 23:21:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemd-analyse plot (105.50 KB, image/svg+xml)
2013-07-16 13:54 EDT, Maarten
no flags Details
boot.log file plymouth-wait-quit failure (9.47 KB, text/x-log)
2013-07-16 17:20 EDT, Maarten
no flags Details
boot with plymouth.enable=0 (9.47 KB, application/octet-stream)
2013-07-16 17:39 EDT, Maarten
no flags Details
Boot with systemd.log_level=debug, output from journalctl -b (139.61 KB, text/x-log)
2013-07-17 12:58 EDT, Maarten
no flags Details
with debug not debugh (323.86 KB, text/x-log)
2013-07-17 17:38 EDT, Maarten
no flags Details
/etc/fstab (697 bytes, text/plain)
2013-07-18 01:49 EDT, Maarten
no flags Details
boot plot comment out (84.04 KB, image/svg+xml)
2013-07-18 14:50 EDT, Maarten
no flags Details
systemctl mask plymouth-start.service (74.61 KB, image/svg+xml)
2013-07-18 16:19 EDT, Maarten
no flags Details
systemctl mask accounts-daemon.service (73.67 KB, image/svg+xml)
2013-07-19 02:04 EDT, Maarten
no flags Details
both accounts daemon and firewall mask (77.93 KB, image/svg+xml)
2013-07-19 02:04 EDT, Maarten
no flags Details
all slow services masked (58.29 KB, image/svg+xml)
2013-07-19 02:05 EDT, Maarten
no flags Details

  None (edit)
Description Maarten 2013-07-16 13:54:24 EDT
Created attachment 774438 [details]
systemd-analyse plot

Description of problem:
Startup time is 1.31min very consistent. Disableling service does not change boot time. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot system
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2013-07-16 15:40:22 EDT
Not sure why this was moved against system since these are the slowdown components..

NetworkManager.service
restorecond.service
accounts-daemon.service
rtkit-daemons.service
plymouth-quit-wait.service
gdm.service
NetworkManager-wait-online.service

And disabling what services? 

( might be related to #985038 )
Comment 2 Maarten 2013-07-16 17:17:59 EDT
LVM, Firewalld, Avahi, chrony. They are all in the 20 seconds on systemd-analyse blame. Remove one. Reboot run blame again. The next one moves up in the 20 second range. (firewall is back on :) ) Included boot.log
Comment 3 Maarten 2013-07-16 17:20:13 EDT
Created attachment 774506 [details]
boot.log file plymouth-wait-quit failure
Comment 4 Maarten 2013-07-16 17:39:33 EDT
Created attachment 774509 [details]
boot with plymouth.enable=0
Comment 5 Maarten 2013-07-16 17:41:11 EDT
Boottime does not change. 

Startup finished in 1.201s (kernel) + 959ms (initrd) + 1min 31.927s (userspace) = 1min 34.088s
Comment 6 Michal Schmidt 2013-07-17 02:15:35 EDT
Please boot with "systemd.log_level=debug" on the kernel command line and then attach the output of the command "journalctl -b".
Comment 7 Maarten 2013-07-17 12:58:28 EDT
Created attachment 774861 [details]
Boot with systemd.log_level=debug, output from journalctl -b
Comment 8 Jóhann B. Guðmundsson 2013-07-17 13:09:00 EDT
That output does not contain debug output since you added "systemd.log_level=debugh" debugh instead of debug so you need to do it again and can you attach your /etc/fstab as well since there is most likely something wrong with it 

systemd[1]: Mounted /mnt/26CEDA80CEDA47A7.

jul 17 18:55:00 localhost.localdomain systemd[1]: Job dev-disk-by\x2duuid-48A00C08A00BFAE8.device/start timed out.
jul 17 18:55:00 localhost.localdomain systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-48A00C08A00BFAE8.device.
jul 17 18:55:00 localhost.localdomain systemd[1]: Dependency failed for /mnt/48A00C08A00BFAE8.

What are you mounting here 

/mnt/26CEDA80CEDA47A7?

and here

/mnt/48A00C08A00BFAE8 < which is failing?
Comment 9 Maarten 2013-07-17 17:38:34 EDT
Created attachment 774991 [details]
with debug not debugh

Sorry, microsoft natural F10 is h when not in f-lock whish is special spell funcion.
Comment 10 Jóhann B. Guðmundsson 2013-07-17 18:49:22 EDT
Still missing your /etc/fstab
Comment 11 Maarten 2013-07-18 01:49:38 EDT
Created attachment 775108 [details]
/etc/fstab
Comment 12 Jóhann B. Guðmundsson 2013-07-18 13:07:37 EDT
What happens if you comment out those mnt entries there and or change them to use UUID= instead ( you can just run the blkid command to find the UUID entries )
Comment 13 Maarten 2013-07-18 14:50:22 EDT
Created attachment 775468 [details]
boot plot comment out

Looks a lot better now. 37s is ok.
Comment 14 Jóhann B. Guðmundsson 2013-07-18 14:57:00 EDT
37s is probably what people get out from our crappy defaults on rotating media. 

By disabling the stuff you dont actually need ( unless you need everything there ) you should be able to get down to 12s on rotating media and about <4s on SSD

What kind of hardware are you running on?
Comment 15 Maarten 2013-07-18 15:17:22 EDT
CPU: Intel(R) Core(TM)2 Duo E8400  @ 3.00GHz
Memory: 2GB
Motherboard: ASUS P5Q  (intel P45)
Videocard: [AMD/ATI] RV620 LE [Radeon HD 3450]
Harddrive: Seagate Barracuda 7200.12 500GB ( ST3500418AS ). 

Already tried to turn off as much as possible. 12s would be nice :). 

Still have this boot error message. 
[FAILED] Failed to start Wait for Plymouth Boot Screen to Quit.
See 'systemctl status plymouth-quit-wait.service' for details.

Looks like most time is spent on this in the boot plot.
Comment 16 Maarten 2013-07-18 16:19:25 EDT
Created attachment 775500 [details]
systemctl mask plymouth-start.service

Startup from 37s to 25s without plymouth. Seems like a bit much. Just benchmarking for fun here
Comment 17 Maarten 2013-07-19 02:04:14 EDT
Created attachment 775642 [details]
systemctl mask accounts-daemon.service
Comment 18 Maarten 2013-07-19 02:04:52 EDT
Created attachment 775643 [details]
both accounts daemon and firewall mask
Comment 19 Maarten 2013-07-19 02:05:37 EDT
Created attachment 775644 [details]
all slow services masked
Comment 20 Lennart Poettering 2013-09-12 23:21:30 EDT
Looks like it was the same as bug 983688

*** This bug has been marked as a duplicate of bug 983688 ***

Note You need to log in before you can comment on or make changes to this bug.