Bug 985077 - [RFE][glance] Asynchronous Processing in Glance
[RFE][glance] Asynchronous Processing in Glance
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ga
: 6.0 (Juno)
Assigned To: Flavio Percoco
nlevinki
https://blueprints.launchpad.net/glan...
upstream_milestone_juno-rc1 upstream_...
: CodeChange, FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 13:55 EDT by Flavio Percoco
Modified: 2016-04-26 13:19 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-glance-2014.2-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-09 09:59:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 111441 None None None Never
OpenStack gerrit 42817 None None None Never

  None (edit)
Description Flavio Percoco 2013-07-16 13:55:43 EDT
Provide and use an internal library api for asynchronous processing in glance, to do things like image imports (asynchronously processing a copy-from). This can later be used to support image conversion and metadata extraction, though those should fall under other blueprints. A simple eventlet thread-based implementation may be provided, alongside something more like a remote rpc queue worker. There should be room for the implementation of the library api to be backed by other cool drivers.

Upstream blueprint: https://blueprints.launchpad.net/glance/+spec/async-glance-workers
Comment 2 Scott Lewis 2013-08-01 13:36:37 EDT
Matched priority to upstream.
Comment 12 errata-xmlrpc 2015-02-09 09:59:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0150.html

Note You need to log in before you can comment on or make changes to this bug.