Bug 985085 - Install virt.group file into /var/lib/glusterd/groups/
Install virt.group file into /var/lib/glusterd/groups/
Status: CLOSED DUPLICATE of bug 1053854
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 14:25 EDT by Vijay Bellur
Modified: 2015-11-03 18:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-27 13:43:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijay Bellur 2013-07-16 14:25:44 EDT
Description of problem:

Installing virt.group file to /var/lib/glusterd/groups helps in overcoming problems like this:

http://lists.ovirt.org/pipermail/users/2013-July/015051.html

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Deepak C Shetty 2013-07-17 06:48:39 EDT
Vijay,
    I was curious to understnad this better. I am not sure how just adding the 'virt' group makes the problem go away. The real reason for "Unable to attach domain to DC" from engine log is not clear... The 'virt' group just enables/disables certain xlators .. so that shouldn't cause issues with oVirt storage domain attach flow.

   My bet is that it happened because the person didn't set the 36.36 perms on the Gluster storage bricks... but still adding 'virt' group doesnt enable those perms... so its unclear how 'virt' group file missing causes the issue in oVirt.

   Can you enlighten pls ?

thanx,
deepak
Comment 2 Niels de Vos 2014-09-27 13:43:50 EDT
The group file 'virt' gets installed since bug 1053854.

*** This bug has been marked as a duplicate of bug 1053854 ***

Note You need to log in before you can comment on or make changes to this bug.