This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 985090 - command "rhsmcertd" options
command "rhsmcertd" options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.5
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel65 1115818
  Show dependency treegraph
 
Reported: 2013-07-16 14:37 EDT by Sharath Dwaral
Modified: 2014-07-03 03:55 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: rhsmcertd tab completion displayed incorrect options. Consequence: Incorrect options displayed. Fix: Update the tab completion script. Result:
Story Points: ---
Clone Of:
: 1115818 (view as bug list)
Environment:
Last Closed: 2013-11-21 16:26:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2013-07-16 14:37:18 EDT
Description of problem:
Command rhsmcertd options

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.8.13-1.el5_9
subscription-manager-migration-1.8.13-1.el5_9
python-rhsm-1.8.13-1.el5_9
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-firstboot-1.8.13-1.el5_9
subscription-manager-debuginfo-1.8.13-1.el5_9
subscription-manager-gui-1.8.13-1.el5_9

How reproducible:
Always

Steps to Reproduce:
1. rhsmcertd <tab tab>
It tab completes to the following with "-h" as a suggestion

# rhsmcertd -
--auto-attach-interval  --cert-check-interval   -d                      -h                      --help                  -n                      
-c                      --cert-interval         --debug                 --heal-interval         -i                      --now


# rhsmcertd -h
Invalid argument specified: -h
For more information run: rhsmcertd --help


# rhsmcertd --help
Usage:
  rhsmcertd [OPTION...] 

Help Options:
>>  -?, --help                             Show help options

Application Options:
  --cert-interval=MINUTES                deprecated, see --cert-check-interval
  -c, --cert-check-interval=MINUTES      interval to run cert check (in minutes)
  --heal-interval=MINUTES                deprecated, see --auto-attach-interval
  -i, --auto-attach-interval=MINUTES     interval to run auto-attach (in minutes)
  -n, --now                              run the initial checks immediately, with no delay
  -d, --debug                            show debug messages


Actual results:
As show above

Expected results:
-h should display help menu
--help should not show '?' 

Additional info:
Comment 1 RHEL Product and Program Management 2013-07-16 14:48:51 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Sharath Dwaral 2013-07-16 15:58:35 EDT
"rhsm-icon" options

tab completion suggests "-h"

# rhsm-icon -h
option parsing failed: Unknown option -h

# rhsm-icon --help-all
Usage:
  rhsm-icon [OPTION...] 

Help Options:
>>  -?, --help                  Show help options
  --help-all                  Show all help options
  --help-gtk                  Show GTK+ Options

GTK+ Options
  --class=CLASS               Program class as used by the window manager
  --name=NAME                 Program name as used by the window manager
  --screen=SCREEN             X screen to use
  --sync                      Make X calls synchronous
  --gtk-module=MODULES        Load additional GTK+ modules
  --g-fatal-warnings          Make all warnings fatal

Application Options:
  -c, --check-period          how often to check for validity (in seconds)
  -d, --debug                 show debug messages
  -f, --force-icon=TYPE       force display of the icon (expired, partial or warning)
  -i, --check-immediately     run the first status check right away
  --display=DISPLAY           X display to use

Actual results:
As show above

Expected results:
-h should display help menu
--help should not show '?'
Comment 3 Bryan Kearney 2013-07-16 16:47:32 EDT
This seems to be an issue with RHEL 5, moving it to ON_QA for RHEL6. We will not bother fixing this for RHEL5.
Comment 6 Sharath Dwaral 2013-08-27 11:47:06 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-firstboot-1.9.5-1.el6.x86_64
subscription-manager-migration-data-1.12.3.2-1.el6.noarch
python-rhsm-1.9.4-1.el6.x86_64
subscription-manager-gui-1.9.5-1.el6.x86_64
subscription-manager-1.9.5-1.el6.x86_64
subscription-manager-migration-1.9.5-1.el6.x86_64

Verification:

Command : rhsmcertd

rhsmcertd <tab tab>

# rhsmcertd -
--auto-attach-interval  --cert-check-interval   -d                      -h                      --help                  -n                      
-c                      --cert-interval         --debug                 --heal-interval         -i                      --now                   


# rhsmcertd -h                <<<<<<<<<<<<  -h works
Usage:
  rhsmcertd [OPTION...] 

Help Options:
  -h, --help                             Show help options   <<<<<<< -h displayed

Application Options:
  --cert-interval=MINUTES                deprecated, see --cert-check-interval
  -c, --cert-check-interval=MINUTES      interval to run cert check (in minutes)
  --heal-interval=MINUTES                deprecated, see --auto-attach-interval
  -i, --auto-attach-interval=MINUTES     interval to run auto-attach (in minutes)
  -n, --now                              run the initial checks immediately, with no delay
  -d, --debug                            show debug messages



Command: rhsm-icon

rhsm-icon <tab tab>

# rhsm-icon -
-c,                   --check-period,       --debug,              -f,                   -h,                   --help-all,           -i,                   
--check-immediately,  -d,                   --display             --force-icon,         --help,               --help-gtk,  
         
# rhsm-icon -h       <<<<<<<<<<  -h option works
Usage:
  rhsm-icon [OPTION...] 

Help Options:
  -h, --help                  Show help options        <<<<<<< -h displayed
  --help-all                  Show all help options
  --help-gtk                  Show GTK+ Options

Application Options:
  -c, --check-period          how often to check for validity (in seconds)
  -d, --debug                 show debug messages
  -f, --force-icon=TYPE       force display of the icon (expired, partial or warning)
  -i, --check-immediately     run the first status check right away
  --display=DISPLAY           X display to use


VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 16:26:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.