Bug 985092 - Wrong filter named "Filters" under Systems -> Subscriptions -> Available Subscriptions
Wrong filter named "Filters" under Systems -> Subscriptions -> Available Subs...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-07-16 14:47 EDT by sthirugn@redhat.com
Modified: 2013-10-01 07:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:03:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Filters dropdown options (232.62 KB, image/x-xcf)
2013-07-16 14:47 EDT, sthirugn@redhat.com
no flags Details
Filters dropdown options in png format (76.46 KB, image/png)
2013-07-16 15:01 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-07-16 14:47:51 EDT
Created attachment 774446 [details]
Filters dropdown options

Description of problem:
Wrong filter named "Filters" under Systems -> Subscriptions -> Available Subscriptions

Version-Release number of selected component (if applicable):
* candlepin-0.8.17-1.el6.noarch
* candlepin-cert-consumer-ibm-x3650-04.ovirt.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.17-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.123.5415a3c.el6.noarch
* katello-cli-common-1.4.2-1.git.123.5415a3c.el6.noarch
* katello-common-1.4.2-1.git.846.c3e1652.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.846.c3e1652.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.846.c3e1652.el6.noarch
* katello-headpin-1.4.2-1.git.846.c3e1652.el6.noarch
* katello-headpin-all-1.4.2-1.git.846.c3e1652.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Login to WebUI
2. Navigate to Systems -> Subscriptions -> Available Subscriptions -> Click on the filter dropdown

Actual results:
The following options are shown:
Filters, Match System, Match Installed Software, No Overlap with Current

Expected results:
"Filters" should not be shown.
The following options are shown:
Match System, Match Installed Software, No Overlap with Current

Additional info:
Comment 1 sthirugn@redhat.com 2013-07-16 15:01:00 EDT
Created attachment 774448 [details]
Filters dropdown options in png format
Comment 2 Tom McKay 2013-07-18 14:51:15 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: d177267a8edbda0d3df88bd8a9d0573b20a742e1
      https://github.com/Katello/katello/commit/d177267a8edbda0d3df88bd8a9d0573b20a742e1
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-07-17 (Wed, 17 Jul 2013)
Comment 3 Bryan Kearney 2013-08-02 14:52:40 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 4 sthirugn@redhat.com 2013-08-12 17:32:19 EDT
VERIFIED. "Filters" option is now not shown. 

Packages tested:
* candlepin-0.8.19-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.19-1.el6sam.noarch
* candlepin-tomcat6-0.8.19-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-5.el6sat.noarch
* katello-cli-common-1.4.3-5.el6sat.noarch
* katello-common-1.4.3-6.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
* katello-headpin-1.4.3-6.el6sam_splice.noarch
* katello-headpin-all-1.4.3-6.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 6 errata-xmlrpc 2013-10-01 07:03:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.