Bug 985131 - bugs.gluster.com should redirect to bugzilla.redhat.com, preferably redirecting bug ids too
bugs.gluster.com should redirect to bugzilla.redhat.com, preferably redirecti...
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
3.4.0
All All
unspecified Severity low
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 17:45 EDT by Pierre-Francois Laquerre
Modified: 2014-07-11 14:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-11 14:14:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre-Francois Laquerre 2013-07-16 17:45:03 EDT
Description of problem:

Ever since gluster's bug tracker moved from bugs.gluster.com to bugzilla.redhat.com, old urls have become invalid. The mailing list is full of these, e.g. http://dev.gluster.com/pipermail/glusterfs/2011-July/004938.html points to http://bugs.gluster.com/show_bug.cgi?id=3171. This link is now a 404.

Steps to Reproduce:
1. Open http://bugs.gluster.com/show_bug.cgi?id=3171 in a browser

Actual results:
404

Expected results:
At the very least a redirection to bugzilla.redhat.com. Even better would be a redirection to the corresponding bug.
Comment 1 Harshavardhana 2013-08-11 00:46:22 EDT
Old url's are not valid agreed but there is a work-around - may be this is sufficient for now? 

https://bugzilla.redhat.com/show_bug.cgi?id=GLUSTER-3171

So every bug from bugs.gluster.com is 'GLUSTER-<old_gluster_bugid>' - pretty simple in chrome. 

Cheers
--
Harsha

Note You need to log in before you can comment on or make changes to this bug.