Bug 985154 - csprocessor fails to pickup invalid links due to conditions
csprocessor fails to pickup invalid links due to conditions
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 20:25 EDT by Lee Newson
Modified: 2013-07-22 21:33 EDT (History)
0 users

See Also:
Fixed In Version: 0.33.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 23:53:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-07-16 20:25:29 EDT
The csprocessor currently will not pick up if a xref link is invalid if the target is inside of a condition that isn't included in a book.

eg

Topic 1:

<xref linkend="my-table"/>

Topic 2:

<table id="my-table" condition="my-book">
   ...
</table>

If a condition other than "my-book" was specified than the book would fail to build in publican, due to the table missing. This would normally be catched and handled by the csprocessor, however because the checks are done before conditions are processed this isn't happening.
Comment 1 Lee Newson 2013-07-16 23:53:51 EDT
Fixed in 0.33.3

The csprocessor will now do an extra step to process all the topics XML to remove conditional statements before doing the link checks.

Note You need to log in before you can comment on or make changes to this bug.