Bug 985162 - Install doesn't allow logical volume naming or placement
Install doesn't allow logical volume naming or placement
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 21:33 EDT by Alex Williamson
Modified: 2013-07-17 11:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 11:40:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Williamson 2013-07-16 21:33:16 EDT
Description of problem:
Installed RHEL7 to an already initialized disk with an existing volume group.  The RHEL7 install gave me no option that I could find to actually name the logical volume, leaving the very non-creative name of "root".  I actually feel exceptionally lucky that the mount point was created on the existing volume group because I also had no choice of placement.  Where's the advanced partitioning tool?  This is a huge regression and loss of functionality from RHEL6 or even RHEL5.

Version-Release number of selected component (if applicable):
RHEL7 pre-beta

How reproducible:
Didn't try

Steps to Reproduce:
1. Start with a preconfigured disk with plenty of space
2. Install RHEL7 using the GUI
3. Attempt to name the logical volume that RHEL7 will be installed to or have any visibility how the disk is configured.

Actual results:
Fail.  Now I have to rename my logical volume, updating grub and initrd, all so the installer is more streamlined?

Expected results:
RHEL6 can do this, why can't RHEL7?

Additional info:
Comment 2 David Lehman 2013-07-17 11:11:03 EDT
https://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/Create_LVM-x86.html

In the image on that page, notice the text entry labelled "Name" near the top, the dropdown menu labelled "Volume Group", and the button right next to that labelled "Modify".
Comment 3 Alex Williamson 2013-07-17 11:24:03 EDT
I was never presented with that dialog.  I clicked the [+] and got a two line dialog that only asked for the mount point and size.  I had no other options.
Comment 4 Alex Williamson 2013-07-17 11:40:54 EDT
I see now that after I get the dialog I mention, the one you indicate is shown.  My bad.

Note You need to log in before you can comment on or make changes to this bug.