Bug 985168 - nslookup issue with engine-setup
nslookup issue with engine-setup
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-installer (Show other bugs)
3.2
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Sandro Bonazzola
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-16 22:10 EDT by Hetz Ben Hamo
Modified: 2013-07-24 08:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-19 02:12:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first part of engine-setup log output (47.81 KB, text/plain)
2013-07-16 22:10 EDT, Hetz Ben Hamo
no flags Details

  None (edit)
Description Hetz Ben Hamo 2013-07-16 22:10:50 EDT
Created attachment 774590 [details]
first part of engine-setup log output

This issue has been discussed on the net and I still don't see any solution. I'm with Fedora 19 and ovirt (from Fedora 19).

I've set in /etc/hosts the machine name as well as in /etc/sysconfig/network

# cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
10.0.0.20   vms.hetz.biz

I can ping it, I can ssh to it (all from the same machine), but the engine-setup scripts uses nslookup which naturally fails.

Do I have to setup a DNS server? why is it ignoring the hosts file?

engine-setup log files enclosed.
Comment 1 Sandro Bonazzola 2013-07-17 07:10:13 EDT
Is 3.2 supported on Fedora 19?
Comment 2 Hetz Ben Hamo 2013-07-17 07:13:07 EDT
Sandro, 

the problem with the ovirt repo on Fedora 19 (if I add this repo) is that it will install the oVirt from Fedora 18, and there is already oVirt in Fedora 19 without this repo
Comment 3 Hetz Ben Hamo 2013-07-17 08:41:37 EDT
More info: issue seems solved with nightly-build and with engine-setup-2 script instead of engine-setup
Comment 4 Itamar Heim 2013-07-17 09:01:40 EDT
(In reply to Sandro Bonazzola from comment #1)
> Is 3.2 supported on Fedora 19?

I think we should aim 3.3 for fedora 19 at this point.
Comment 5 Hetz Ben Hamo 2013-07-17 09:07:38 EDT
Could someone mention on the installation pages of oVirt to not run the release on F19? I spent 8 hours on this yesterday.
Comment 6 Sandro Bonazzola 2013-07-19 02:12:26 EDT
I've no rights for updating http://www.ovirt.org/Download , can you please add a note in that page to use nightly or beta repo on F19 because 3.2 stable is not supported there?

Closing this bug as nextrelease since this issue won't be fixed in 3.2 and is already fixed for 3.3.0.
Comment 7 Michal Skrivanek 2013-07-24 08:21:05 EDT
"Fedora 19 is not supported for 3.2, please use 3.3 if you want to use Fedora 19 " added to ovirt.org download page

Note You need to log in before you can comment on or make changes to this bug.