Bug 98517 - rpm database verification failed
rpm database verification failed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 02:04 EDT by Thomas Emde
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 10:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Emde 2003-07-03 02:04:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows NT 5.0; U) Opera 7.11  [en]

Description of problem:
After trying to install a self-built package, the rpm database seems to be 
corrupted. rpm -q tells that the package is not installed, rpm -Uvh <package> 
tells the following:
Preparing...                ########################################### [100%]
package <package> is already installed
rpmdb: Overflow item incomplete on page 3492
error: db4 error(-30979) from db->verify: DB_VERIFY_BAD: Database verification 
failed

rpm --rebuilddb results in a segmentation fault.

Version-Release number of selected component (if applicable):
rpm-4.0.4-7x.18

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Jeff Johnson 2003-07-03 10:57:24 EDT
The following will verify the problem (you need db4-utils):

    db_verify /var/lib/rpm/Packages

Fix is to dump and reload Packages, then rebuild the indices

    cd /var/lib/rpm
    mv Packages Packages-ORIG
    db_dump Packages-ORIG | db_load Packages

    rpm --rebuilddb -vv

Reopen if above does not solve the problem.

Note You need to log in before you can comment on or make changes to this bug.