Bug 985255 - keystone password-update --new-password fails with 404
keystone password-update --new-password fails with 404
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
3.0
x86_64 Linux
high Severity high
: rc
: 4.0
Assigned To: Adam Young
Ami Jeain
: Unconfirmed
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 04:05 EDT by Jaroslav Henner
Modified: 2016-04-26 18:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 13:15:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
detailed information (9.13 KB, text/plain)
2013-07-17 04:05 EDT, Jaroslav Henner
no flags Details

  None (edit)
Description Jaroslav Henner 2013-07-17 04:05:37 EDT
Created attachment 774660 [details]
detailed information

Description of problem:
keystone --debug password-update --new-password foobar fails with ERROR 404

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.23.dev642.el6ost.noarch
openstack-keystone-2013.1.2-2.el6ost.noarch
python-keystoneclient-0.2.3-5.el6ost.noarch


How reproducible:
2/2

Steps to Reproduce:
1. deploy using packstack --allinone
2. . keystonerc_admin
3. keystone --debug password-update --new-password foobar

Actual results:
HTTP 404

Expected results:
Password updated

Additional info:
[root@rhel-preinstalled ~(keystone_admin)]# keystone password-update --new-password foobar
Unable to communicate with identity service: {"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}. (HTTP 404)
Comment 2 Adam Young 2013-12-05 13:15:31 EST
This problem is due to a misconfigured system, not due to a problem with the CLI or Keystone.  The 404 does not happen on a properly configured system.

Note You need to log in before you can comment on or make changes to this bug.